0

I am running a graphics toolbox using Matlab called Psychophysics. I am this close to getting everything working, but I'm having drama with synchronization errors which has to do with my driver settings. Check this post out:

He says the error below is most likely due to a few options needed to be reset, most notably

Option "TripleBuffer"    "off"
Option "SwapbuffersWait"  "on"

My question is how do I even reset these values? He mentioned the xorg.conf file, but I've read in many different places that this file isn't used anymore. I can't find it using the 'find /usr -name xorg.conf' unix command on my system either (and that would take forever). I'm also afraid I will ruin my graphics card if I don't talk to someone who knows their stuff.

Here is my error message:

 PTB-INFO: No low-level controllable GPU on screenId 0. Beamposition
 timestamping and other special functions disabled.

 PTB-DEBUG:PsychOSGetSwapCompletionTimestamp: This likely means a
 driver bug or malfunction, or that timestamping support has been
 disabled by the user in the driver!

 PTB-INFO: OpenGL-Renderer is Intel Open Source Technology Center ::
 Mesa DRI Intel(R) Sandybridge Mobile  :: 3.0 Mesa 10.1.3 PTB-INFO: VBL
 startline = 768 , VBL Endline = -1 PTB-INFO: Will try to use
 OS-Builtin OpenML sync control support for accurate Flip timestamping.
 PTB-INFO: Measured monitor refresh interval from VBLsync = 16.682734
 ms [59.942213 Hz]. (297 valid samples taken, stddev=0.322476 ms.)
 PTB-INFO: Reported monitor refresh interval from operating system =
 16.646968 ms [60.070999 Hz]. PTB-INFO: Small deviations between reported values are normal and no reason to worry.

 WARNING: Couldn't compute a reliable estimate of monitor refresh
 interval! Trouble with VBL syncing?!?

 ----- ! PTB - ERROR: SYNCHRONIZATION FAILURE ! ----

 One or more internal checks (see Warnings above) indicate that
 synchronization of Psychtoolbox to the vertical retrace (VBL) is not
 working on your setup.
  • This X Wiki may help. If the conf file isn't present, the system is auto configured. If the file is present the settings in it are honored. – eyoung100 Jul 29 '14 at 20:41
2

Create a new file in /usr/share/X11/xorg.conf.d called any-name.conf. Put options in there. They get merged into the auto-generated xorg.conf when X starts.

Here's something from my machine:

% cat /usr/share/X11/xorg.conf.d/20-intel.conf
Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "AccelMethod"  "sna"
  Option      "TearFree"    "true"
EndSection

Make sense?

-1

I think I solved the issue relating to this.

I'll just walk through the steps here in this answer (I don't know if there's a better way though)

  • Get the latest intel drivers here and just click on the deb that opens the package manager and click install there. (This could take a lil while)

  • Go to the terminal and execute

    intel-linux-graphics-installer
    
  • Once done, reboot

Now we have to make the xorg.conf file. For this:

  • Create a file called xorg.conf in /etc/X11/. If xorg.conf already exists, back the old one up and create a new one. You will need superuser (sudo) access to edit this file

  • The contents of the xorg.conf follow

    Section "Device"
        Driver      "intel"
        Identifier  "PTB: generic TripleBuffer off"
        Option      "AccelMethod" "uxa"
        Option      "TripleBuffer" "off"
        Option      "SwapbufferWait" "on"
    EndSection
    
  • Now log out and log in again.

Follow these steps and you must be good to go :) Let me know if you face any issues

SC

  • 1
    I'm excited you found it! I followed your instructions, but I found that my X11 folder was not in the /etc directory. It was in the same directory as /etc. I have the R2013b installation of MATLAB. I wonder if this is a mistake? This is how it was downloaded - I did not change the folder hierarchy here. I tried putting X11 in /etc and I tried a few other things. All still have VBL failures. Hmm. – areyoujokingme Aug 3 '14 at 4:02
  • Guy asked how to set xorg.conf values, not how to install drivers from intel, which may cause more problems. – user3113723 Dec 30 '15 at 4:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.