38

Ever since I upgraded to Ubuntu 14.04, Chrome (google-chrome-stable) crashes a lot more often than before.

I do keep several tabs open (>20), but they are all light (no multimedia) and have never caused any problems in the past.

The processor and memory use is pretty low when the browser becomes unresponsive and the whole system is still usable.

Is there an easy fix? Where can I find more logs for a more complete diagnostic?

enter image description here enter image description here

  • Just to verify: The only thing that becomes unresponsive is chrome, correct? When chrome dies, does the rest of the computer slow down/crash as well? – Mitch Jul 29 '14 at 13:13
  • Sorry, I forgot to add that only chrome is affected. Everything else keeps working fine. – Ricky Robinson Jul 29 '14 at 13:15
  • That's fine - I just wanted to verify. Is chrome (and everything else) the newest version? (sudo apt-get update && sudo apt-get upgrade) – Mitch Jul 29 '14 at 13:18
  • 1
    Chromium is the original. It's repackaged as Chrome afterwards. – amanthethy Jul 29 '14 at 13:39
  • 1
    What was your upgrade path to 14.04? Did you install it fresh or upgrade from 13.10? I am curious as I am still experiencing this issue ~2-3 times a day. – robbmj Feb 16 '15 at 0:13
19

I have the same problem - try to run it with --disable-gpu flag, like

google-chrome --disable-gpu

also I use three monitors on two nvidia videocards with opened developer tools (I guess this is the reason)

  • 3
    Welcome! Could you add more details, like the symptoms you had? – Volker Siegel Oct 1 '14 at 7:38
  • that's something new! Thanks. I can't find any documentation for that option, though. Could you describe what it does? – Ricky Robinson Oct 1 '14 at 13:08
  • 1
    I think its a bug between nvidia driver and chrome's rendering, because I've got these crashings after drivers installation – Ivan M Oct 1 '14 at 14:26
  • 1
    I'm getting this with ATI community drivers so not just Nvidia and also when not having developer tools open. – jowan sebastian Nov 14 '14 at 12:09
  • 2
    hmmm interesting, I also use multiple monitors with 2 nvidia cards, and also have dev tools open almost all the time. is the --disable-gpu option different to the use hardware acceleration when available option in advanced settings? – Horse Feb 16 '15 at 12:51
5

Check out this post on the Google Chrome Help Forum. However, unlike you, the whole system is hanging. I only post it here because it might help other people who come across your post based on the title you gave it. It looks like the system hanging issue might be something to do with Radeon cards so if you don't have one it might not be relevant to you.

  • Make sure you have sufficient swap space if the whole system is hanging up. – Gayan Weerakutti Feb 7 '16 at 15:33
3

I've had similar issues with Chromium since upgrading to Ubuntu 14.10. Bumping the limit of open files as in my other answer (by using ulimit in bash or editing limits.conf) seems to resolve the issue for me. Summary:

In a shell, run:

ulimit -a

Check the line that reads open files (or run ulimit -n right away). On my system, the value is 1024. Quit Chromium. Then, in the same terminal, issue

ulimit -n 4096
chromium-browser

Replace 4096 by a value suitable for your system. You should be able to use more tabs in this browser session. Once you have found a reasonable limit, persist it in limits.conf:

*                hard    nofile          4096
*                soft    nofile          4096
  • add a line to /etc/pam.d/common-session*:
session required pam_limits.so
  • logout / reboot to apply changes

References:

1

I know a solution that worked for me, it seems its related to the shell you are using. I was using gnome-flashback as session instead of Unity. When i uninstalled that and used the default Unity again i had no crashes. This hasn't been confirmed yet but from preliminary tests its the case. So the problem seems to lie with Gnome 3 ? Possibly opensource drivers and Chrome, although i doubt its a problem with chrome.

One more thing ... this occurred only on the 64 bit versions of chrome, thus I believe it might only affect 64 bit systems.

  • I also notice the same patterns described here. Not sure if that's the cause, but I don't experience this on any chipset of unity flavors, only gnome flavors of Ubuntu. – Brian Vanderbusch Nov 1 '14 at 22:50
  • 1
    guys im using ubuntu 14.04(64bit) with unity and chrome still crashes and the whole computer hangs – john Jan 18 '15 at 6:50
0

He's dead, Jim!

Just isn't as funny as it used to be.

By the way, Chromium tells me:

Boo... You have no extensions :-( Want to browse the gallery instead?

It must be something else -- I've always suspected that this is related either to Flash or to JavaScript run by ads/trackers.

Something that has helped: Open the task manager (shift+esc) and just click the End process button until you've closed everything but Browser and GPU Process (these two can't be closed). Now go back to the websites that were crashing and try again.

After killing all of your tabs in this way, you can go back and reload pages with F5 on an as-needed basis. This is the way web browsers should work anyway -- pages release resources and hibernate when not in use.

Long story short, I think Chromium has moved away from its original sandbox-per-page architecture, so now there is a great-deal of interdependence between running web pages -- and this results in the infamous sad-tab, which tends to come in bunches.

It's hard to keep a web-browser running great over time. I hate to say it (or do it), but sometimes you just have to throw up your hands and go back to Firefox.

  • On a couple of occasions, this has caused my computer to initiate a shut down sequence. I don't have the foggiest idea why. I think there was some kind of "mystery process" in the chromium task manager that shouldn't be shut down. So the modified suggestion is -- go slowly through the list of of processes and be observant about what processes you are terminating. – nobar Sep 15 '15 at 18:02
0

To disable GPU, another method is through user settings.

  1. Disable the setting: Use hardware acceleration when available

    chrome://settings/search#hardware%20acceleration
    
  2. After restarting browser, check gpu status

    chrome://gpu
    

    You should see everything set to software.

protected by Community Jan 23 '15 at 15:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.