1

I can obviously type it my browser and even in Xterm, but not in Konsole. I'm using Kubuntu, 13.10. To be thorough, I am using a German keyboard (which is already a pain), but I don't see why that should matter. In Konsole, I can type the other character ('°') on the same key.

I use this all the time in vim and it's annoying to copy and paste it. I saw something similar here, but it wasn't solved. One of the answers asked if the problem was reproduced in kate; it is.

I could use another terminal emulator, I guess, but it would be nice to use Konsole.

  • 1
    What happens if you type ^ twice or ^ and ` ` (space)? Did you research on the web a bit before you posted your Q here? – Run CMD Jul 29 '14 at 11:45
  • Nice. The ^ and then space works. Thanks. I did search the web, but I was spelling caret wrong, and using ^ in my search gave me nothing. – MrUser Jul 29 '14 at 12:28
  • You should also consider upgrading 13.10 is not supported since July 17. – Warren Hill Jul 29 '14 at 12:34
  • I upgrade my OSs like I pay my taxes: late or never. – MrUser Jul 29 '14 at 12:39
1

There have been many discussions about dead keys, how they should be used to be able to generate accented characters, etc. The behaviour of characters such as ~ and ^ may depend on your system's locale settings and the input method of the specific program.

I personally find this bug report interesting.

If you hit a special character's key and nothing happens, chances are that the system is waiting whether you mean to input an accented character. Hitting (space) should usually get you the character itself.

Not the answer you're looking for? Browse other questions tagged or ask your own question.