0

After installing Ubuntu 64bit UEFI Image with the CSM Disable setting, I have two entries in the boot menu. These two entries show the same name: Ubuntu:XXXXXXX.

I can't find any difference between them, are they the same or is there a difference?

  • Which boot menu are you even talking about? BIOS? GRUB? – Run CMD Jul 29 '14 at 7:26
  • BIOS Boot Mananger – user310194 Jul 29 '14 at 10:09
  • My UEFI BIOS lists 2 entries per bootable device; 1 for legacy USB boot and 1 for EFI enabled boot. But this is indicated in the list. Still, I additionally have these entries 2 times, because I replicated the EFI boot partition on a 2nd device. -- Without a screenshot or a bit more background from your side, it's impossible to tell what you see (and why), though. – Run CMD Jul 29 '14 at 10:23
0

In an Ubuntu terminal window, type:

sudo efibootmgr -v

This will show you details for all the boot entries in your EFI's boot manager. Examine the details for the two ubuntu entries to see if they differ. If they don't, it's safe to remove one of them via the -b # -B option, as in:

sudo efibootmgr -b 4 -B

This example deletes the Boot0004 entry. I recommend deleting the entry that comes later (or not at all) in the BootOrder list (which is also shown by efibootmgr -v).

It's also safe to delete an entry if it refers to a non-existent file, partition, or disk. Unfortunately, the partition and disk identification is done via long strings that are difficult for humans to parse. You might have such an old entry if you installed Ubuntu twice.

Note that there are certain bugs that can cause these entries to multiply. In particular, an interaction of a buggy EFI and a buggy version of Shim can cause this problem. If you run into this condition, I recommend disabling Secure Boot and bypassing Shim. The former requires entering your firmware setup utility, finding the Secure Boot option (its location and name varies, unfortunately), and disabling it. The latter requires creating a new NVRAM entry that points directly at GRUB, rather than at shim:

sudo efibootmgr -c -l \\EFI\\ubuntu\\grubx64.efi -L "GRUB direct"

IIRC, the buggy version of shim is distributed with Fedora, and Ubuntu's version is unaffected, so chances are you should not see this problem if you're using Ubuntu's Shim.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.