I just started using Ubuntu GNOME 14.04 LTS. From the 'Help' application I see that there ought to be certain icons if I am using a wired connection on my GNOME top bar as shown below:

enter image description here

But there isn't any! I see only a couple of icons on my top bar as shown below:

enter image description here

So how to get those icons on my top bar? I can't right click on the top bar too! I am not able to know if I am connected to the internet without this. I ought to enter my browser and search for google or something to know if I am connected. So need help here!

PS:- BTW I see that there aren't many icons on my top bar. Is this normal? Am I missing any other default icons? If yes can you tell how to get those? BTW I have libappindicator 1 and libappindicator 3-1 installed. So, that shouldn't be a problem. Also I tried this but it didn't work. Let me also add that I changed to a different icon theme too but that also didn't help(presently using numix-circle theme). The default tweak tool also doesn't seem to have any options to solve this issue of mine.

2 Answers 2


This was by design: Debian Bug #708966

For machines that are permanently connected to a wired connection, that icon is mostly noise. In most cases you are always connected, and the status never changes. The icon is uninteresting and gets in the way of the information that has utility.

There are many cases where a wired connection comes very close to being a physical part of the machine itself (eg. computer labs, etc).

With the new model, every icon in the top bar has an associated submenu with options. However, in the case of wired, there are no options that are of use to the vast majority of users. The proportion of people needing to turn off their wired connection is very small indeed.

Even in newer versions, the icon is showed only if some action can be taken on the wired connection (for example, multiple profiles are present).

  • so since i am always gonna be connected they wont let me know i am connected! right. My top bar is normal then. Thanks! (BTW from the viewpoint of someone coming from unity GNOME is tooooo minimal and i kinda like it!)
    – Venkatesh
    Jul 29, 2014 at 7:17
  • @Venki Yeah, it drove me nuts the first time I encountered it. But one gets used to it now. :)
    – muru
    Jul 29, 2014 at 7:21
  • @VenkiPhy6 Actually, I felt it was weird at first too, but it makes sense. Show stuff only when it is not working as expected. Clean. :D
    – IcyFlame
    Sep 10, 2015 at 6:13

This extension may be a satisfying workaround.

It is the only one that works (as I have found so far).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.