4

I am using macbook pro with Ubuntu. When I touch the touchpad with two fingers, there are two scenarios that can happen:

  1. I tap with two fingers, a mouse right click is simulated
  2. I slide with two fingers, a scroll is simulated

However I find that if I slide a short distance, the touchpad first understands it as a scroll and fires scroll event, but then it also fires a right mouse click.

What I want to tweak is to make the touchpad fire scroll event only when I slide my fingers a very short distance, is there something like a threshold to adjust?

2 Answers 2

1

What I did was to simulate more the Mac behaviour, for the right click, you put two fingers in the touchpad and then tap with another finger.

This is accomplished with a package, install it with:

sudo add-apt-repository ppa:mactel-support && sudo apt-get update && sudo apt-get install xserver-xorg-input-mtrack

Then, create a file in '/etc/X11/xorg.conf', I use nano, you can use gedit if want a window application, just replace nano with gedit:

sudo nano /etc/X11/xorg.conf

And insert this in that file:

Section "InputClass"
     MatchIsTouchpad "on"
     Identifier      "Touchpads"
     Driver          "mtrack"
     Option          "Sensitivity" "0.85"
     Option      "FingerHigh" "12"
     Option      "FingerLow" "1"
     Option          "IgnoreThumb" "true"
     Option          "IgnorePalm" "true"
     Option          "TapButton1" "0"
     Option          "TapButton2" "0"
     Option          "TapButton3" "0"
     Option          "TapButton4" "0"
     Option          "ClickFinger1" "1"
     Option          "ClickFinger2" "3"
     Option          "ClickFinger3" "3"
     Option          "ButtonMoveEmulate" "false"
     Option      "ButtonIntegrated" "true"
     Option          "ClickTime" "25"
     Option          "TapButton2" "0"
     Option          "TapButton3" "0"
     Option          "TapButton4" "0"
     Option          "ClickFinger1" "1"
     Option          "ClickFinger2" "3"
     Option          "ClickFinger3" "3"
     Option          "ButtonMoveEmulate" "false"
     Option      "ButtonIntegrated" "true"
     Option          "ClickTime" "25"
     Option          "BottomEdge" "25"
     Option      "SwipeLeftButton" "8"
     Option      "SwipeRightButton" "9"
     Option      "SwipeUpButton" "0"
     Option      "SwipeDownButton" "0"
     Option      "ScrollDistance" "75"
     Option      "VertScrollDelta"          "-111"
     Option      "HorizScrollDelta"         "-111"
 EndSection

This will also add the natural scrolling (like default in mac), if you don't want the natural scroll. remove the "VertScrollDelta" and "HorizScrollDelta" lines.

You need to restart Ubuntu.

I did more tweaks on my Ubuntu, you can check them here:

http://lobotuerto.com/blog/2015/03/02/ubuntu-en-una-macbook-pro/

Use a spanish translator or feel free to ask.

Good luck!

1
  • I end up letting my macbook go a few months ago but thanks for your answer anyway, upvoted :)
    – boh
    Mar 4, 2015 at 3:37
1

Settings - Mouse & Trackpad - un-check "tap to click" You then have to actually click the touchpad to fire a mouse click event, rather that the light finger tap that PC touchpads seem to prefer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.