1

I am using Ubuntu 13.10, which I installed almost 6 months back. While installation I selected HOME folder encryption. However, being a newbie I did not note mount passphrase(I thought how important this could be ! apparently that is all I need right now). Everything worked fine until 3 days back. I changed my login password, locked the screen and unlocked it using new password to make sure everything is fine. A few seconds later the computer shut down due to power supply cut-off (yes, battery is dead , hence the machine is directly powered by cable). I restarted the laptop and I was not able to login, the login screen was being thrown back after correct password entry(so basically there was a login loop). However, I was able to login to tty1 with the error message:

" Signature not found in user keyring.
Perhaps try the interactive 'ecryptfs-mount-private'
"

I tried solutions this , this and this. These basically suggest to 1) Deleting ~/.Xauthority
2) sudo chown -R $USER:$USER $HOME
3) sudo dpkg-reconfigure lightdm
4) sudo chmod a+wt /tmp

None of these work.

Now all I hope is to recover my 6 months of work(coding project I was working on). Using sudo ecryptfs-recover-private (either via another account or live usb) prompts me for login passphrase. I tried using the new password or the preceding password. But both throw error:

"Error: Unwrapping passphrase and inserting into the user session keyring failed [-5]
Info: Check the system log for more information from libecryptfs
"

I have changed the login password a couple of times during last 6 months. I only remember last 2 passwords i.e. the one which is throwing login loop and one previous to that.

Could you please tell me if something can be done to recover data ?

2

I had this problem too. From TTY1, you have to change the password to the previous one that was not giving you the problem. Then you should log out and log back in with the old password. After that you can change your password back to the new one and everything should be fixed.

You could also run (taken from this answer):
ecryptfs-rewrap-passphrase /home/.ecryptfs/$USER/.ecryptfs/wrapped-passphrase

  • Had this problem on Xenial 16.04.2 LTS when I force closed during a terminal session and then rebooted after changing my password. The command supplied was exactly the solution, thank you. – Benjamin R Apr 4 '17 at 2:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.