8

I can't seem to get Apache 2.4 to load my xdebug configuration. I've added:

zend_extension=xdebug.so
remote_enable=on

to /etc/php5/apache2/conf.d/20-xdebug.ini.

According to phpinfo() that file does get parsed, but remote_enable is still off.

I don't see any errors in the logs. What else might I be missing?

12

According to xdebug manual:

xdebug.remote_enable Type: boolean, Default value: 0

This switch controls whether Xdebug should try to contact a debug client which is listening on the host and port as set with the settings xdebug.remote_host and xdebug.remote_port. If a connection can not be established the script will just continue as if this setting was 0.

I order to setup remote debugging, you should change your /etc/php5/apache2/conf.d/20-xdebug.ini and add this line:

  zend_extension=/path/to/your/xdebug.so 
  xdebug.remote_enable = 1

You should setup xdebug.remote_port and xdebug.remote_host too.

Read this link for more information on Remote Debugging

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.