I run Ubuntu 12.04.4 LTS 32 bit version and recently took the option to take the HWE upgrade from Update Manager. Now either the computer freezes or I go into a low graphic mode similar to the Terminal. I believe this is because I have an old Nvidia FX5600 graphic card. If I run 3.13.0-32-generic in recovery mode I can use my computer. My question is can I reverse out the HWE upgrade or will I have to reinstall the OS from scratch using the original CD?

  • (?) HWE update is a kernel update so pick an older kernel(?) "low graphic mode" this means your display is not supported. Check for a older xorg.conf file or a backup of it. I would file a bug on launchpad against this update.
    – Rinzwind
    Jul 28, 2014 at 14:47
  • This works in 14.04 LTS (for selecting, removing kernel versions): I have no idea how 12.04 is... askubuntu.com/a/502974/289138
    – Hannu
    Jul 28, 2014 at 14:53
  • If I hold down the shift key when booting to get into the grub menu the default option is 3.13.0-32-generic. However, if I enter in the terminal dpkg --list | grep linux-image the last entry is linux-image-generic-lts-trusty Is this the cause of the problem? If I purge that image with sudo apt-get purge linux-image-generic-lts-trusty and then sudo update-initramfs -u and sudo update-grub will this correct my problem please?
    – user280036
    Jul 28, 2014 at 16:13
  • @Rinzwind HWE upgrade seems to be more fundamental. Earlier kernals do not work either, only recovery mode. Launcher is only a solid green bar but running cursor down shows the text description of icons within but choosing an application freezes computer. Eventually black screen with text unable to write bytes broken pipe. Seems that I will have to reinstall from fresh and ignore hardware updates or choose another Distro more NVidia tolerant.
    – user280036
    Jul 29, 2014 at 10:59

6 Answers 6


NB: This does not answer your question but rather tells you how to fix your problem while still using the new HWE.

Open a terminal (hold in CTRL and ALT while pressing T) Add xorg-edgers PPA and update

sudo add-apt-repository ppa:xorg-edgers/ppa

You'll have to supply your password when prompted. You'll get all sorts of info about this repo but to continue just press ENTER

Now in the same terminal:

sudo add-get update
sudo apt-get install nvidia-304

You need to press Y + ENTER for it to be installed.

When it's finifshed you restart your system. To confirm that you are indeed using Nvidia drivers you may open System settings in the menu on top right and choose Additional Drivers from the Hardware section. It takes some time for it to start up but when it's there it will tell you if you are using Nvidia driver. It might be that you could in fact activate your driver from this view after sudo add-get update but I didn't do that so I'm not 100% sure. Before the HWE update I had several choices here but now I only have the one I have installed.

There is a bug report on this issue and it can happen this problem will be solved upstream. To stop using the PPA:

sudo rm /etc/apt/sources.list.d/xorg-edgers-ppa-precise.list
sudo apt-get update
sudo apt-get install --reinstall nvidia-304 
  • Sorry for not replying sooner Sylwester. I had given up trying to resolve the problem before your answer and did a fresh install. I know this is not ideal but I was desperate. Incidentally,I chose the NVidia 173 version on the new install and I find it much better than the 304 I had before. I will gladly rephrase the question if you think it will help others but I have not tried your answer to see if it works as I don't intend to upgrade to HWE in 12.04
    – user280036
    Aug 4, 2014 at 19:57
  • @user280036 Seems like bain has done it quite nicely by just changing title.
    – Sylwester
    Aug 6, 2014 at 10:46

The core problem is that the HWE update doesn't install the headers for the new kernel. These headers are necessary for the NVidia driver to build its kernel module. To fix it, simply install the linux headers and then reinstall whatever nvidia driver you're using:

sudo apt-get install linux-headers-generic-lts-trusty

Note: this is for Ubuntu 12.04.5, if you're using a later release, it's going to be linux-headers-generic-lts-RELEASENAME.

Then when you reinstall the nvidia driver and reboot, you should be fine once again.


I had the same issue: after upgrade I could only boot into the tty screen. After trying numerous fixes, I happened to notice that the Nvidia kernel was using driver 173, while the rest of the conf was 304. The only solution was to disable 304 and enable 173 using jockey-text:

sudo jockey-text -e xorg:Nvidia_173

now working as before.


I have met with this same problem and I tried a lot of methods. The method given by Sylwester does not work for me. The method by Joecool almost work for me but I have to change some parameter. I type:

sudo jockey-text -e xorg:Nvidia_331

the restart the computer and everything will be find. And how can I know it is 331, I type:

sudo jockey-text --list

and find out that

xorg:nvidia_304 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
xorg:nvidia_304_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, enabled, Not in use)
xorg:nvidia_331 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
xorg:nvidia_331_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)

so I enable the 331, and everything was okay


I had te same issue, though I don't know was grahic cards I was running.

Pressing F12 got me into grub. Going to failsafe mode then getting a command line. I did an apt-get upgrade. Rebooted and then it worked.


I just had this same issue while upgrading my HWE on 12.04.

After upgrading, everything worked fine for a few minutes and then the screen went distorted and pixelated.

What I had to do was hard restart the PC and enter into recovery mode on reboot. I enabled networking and then dropped to the root shell. There I apt-get updated/upgraded and then rebooted again into normal mode. No icons loaded this time and I rebooted again. Another reboot appeared to fix the problem.

It looks like it was caused by a NVIDIA driver Bug Screen freeze and garbled after resume from suspend

Hope this helps someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .