11

I have an issue I'm not sure how to work out. On Ubuntu 14.04, after sleeping the keyboard will be non-responsive most of the time on the lightdm login screen. It's not completely non-responsive: I can still Ctrl+Alt+F1 into a virtual terminal to restart the lightdm service and everything is alright. However, obviously anything I left behind when I originally put the laptop to sleep has now been washed away, somewhat defeating the purpose.

Where do I look to figure out what the problem might be?

Edit:

As it turns out, the original solution I found does not solve the problem. It still recurs fairly frequently (without reinstalling the input package over and over again). In this case the mouse and keyboard work fine, except for typing a password into the box. This can be solved simply by highlighting some other GUI element, for example I click the power button in the top right. After that the text input works fine again. It's a bit bizarre...

7
  • How are you putting it to sleep?
    – Tim
    Jul 28, 2014 at 11:50
  • Closing my laptop lid. I just tested using a function key + sleep and everything worked fine, although I'll probably want to try that a few more times.
    – Anthony
    Jul 28, 2014 at 11:52
  • Would you be happy to disable the sleep feature, or are you hoping for a solution not workaround?
    – Tim
    Jul 28, 2014 at 11:54
  • Addendum: Interestingly enough, if I Fn+Sleep then close the lid, then reopen the lid to awake, I get the same issue. Apparently Ubuntu doesn't like being shut away from the world. @Tim: I'd prefer a solution. The sleep functionality on the same laptop with earlier versions of Ubuntu (12.04-13.10 on this laptop) has worked fine, so there is surely just something awry.
    – Anthony
    Jul 28, 2014 at 11:56
  • It coud be a problem with the new greeter?
    – Tim
    Jul 28, 2014 at 11:57

2 Answers 2

7

Well, here's a solution that has seemed to work.

Keyboard and mouse unresponsive after suspend

sudo apt-get install --reinstall xserver-xorg-input-all

EDIT: This fix does not appear to completely work. See edit above.

2
  • I think this has to do with lightdm. Are you on version 1.10.5 as well?
    – mikeymop
    Aug 7, 2015 at 14:24
  • It's possible that was the problem, although I'm not using 14.04 any more so I can't verify. I do not have this issue on either 14.10 or 15.04.
    – Anthony
    Aug 7, 2015 at 14:34
2

I'm having the same issue, although reinstalling the xorg input packages didn't help. Dropping to the console and restarting lightdm does work, so that's a good temporary workaround. Hopefully a fix for lightdm will come soon. This has worked fine on the same laptop for Ubuntu 12 and 13 previously and only started after upgrading to 14.04.

1
  • I know restarting lightdm works, however I can't always drop into the console. Such as when I'm doing a system resume, the keyboard and mouse just wont reconnect. Is there a way to prevent Ps/2 and USB hosts from disconnecting during system suspend?
    – mikeymop
    Aug 7, 2015 at 15:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.