0

I have setup a PXE Boot system where one can boot an Ubuntu live session over the network. Booting and installation both work fine, with the installation able to access the network. Within the live session, the default LAN network interface is set to manual in /etc/network/interfaces:

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet manual

That wouldn't be a problem. The problem is that installed system also has this configuration, and since there's an entry for eth0 (or whatever the name of the interface happens to be) in /etc/network/interfaces, NetworkManager ignores it, leading users to think that their "LAN isn't working in Ubuntu".

There are plenty of things that Ubuntu can copy over from a live session to an installation, such as packages, repository sources, GUI preferences. It doesn't do so for any of those. Why, though, does it retain this network configuration, of all things? How do I stop it from doing so?

1 Answer 1

0

This is a known bug: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/388060 (about 5 years old). It's a rare use-case and unlikely to get fixed, so one workaround would be to preseed a late_command which overwrites the /etc/network/interfaces with only a loopback device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .