0

I'm having problems with some application/x-executable files. They simply don't open. I've tried to click them and I've tried to open them in Terminal, but nothing happens. On Ubuntu 12.04, both of the programs work, just by double-clicking them.

The programs are:

  • fez (setup of Fez game; Humble Bundle edition)
  • supermeatboy (setup of the game; Humble Bundle edition)
  • fusion (executable file of the emulator Kega Fusion)

I've already installed the 32-bit libs (Fusion needs it).

I've tried this in Terminal:

./fez
bash: ./fez: No such file or directory

screenshot of the problem

5
  • I did it. I swear. I know that the most of people who come here to ask questions are new in Linux and Ubuntu, but I'm not. I use Ubuntu since 12.04 version and I know how to use command lines in the Terminal. But I just can't open the executables. Is how i say: returns "No such file or directory". But the file is definitely there! Thanks for the help anyway! Sorry if look like I'm angry or whatever. I swear I'm not. – Rodrigo Sabbat Jul 28 '14 at 23:31
  • Look this image: s23.postimg.org/7r00hal5n/olha_s.png – Rodrigo Sabbat Jul 28 '14 at 23:50
  • What is result of ls -l ~/Downloads (to check the access rights) – Boris Jul 29 '14 at 7:43
  • Returns "Total 0" – Rodrigo Sabbat Jul 29 '14 at 14:16
  • Could you please give the result of ls -la ~/Downloads (to have info about the folder itself .) and cat ~/.config/user-dirs.dirs (to check how are set Nautilus favorites) – Boris Jul 29 '14 at 16:10
1

I had an equivalent issue with an executable file called myExecutable. To work, you need the both following conditions :

  1. The file permission / right must be set as executable :

    • One way is to run the command : chmod +x myExecutable
    • Another way is to do it graphicaly with right clic on the file, property, permission
    • You can check it by looking at x with : ls -l
  2. The mounted file system / partition must allow to run an executable.

    Eg. the file system must be mounted with exec parameter instead of noexec. Look at the file /etc/fstab or check the mounted partition with mount command

Then, you will be able to run the file :

  • With double clic on it
  • Or in running in a console : ./myExecutable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.