1

I am running ubuntu 14.04 on my Notebook with Nvidia optimus. Default intel drivers, nvidia 340.24 + bumblebee. (Those problems are indipendent from nvidia, they persist with either nouveau and various nvidia drivers and either with bumblebee and nvidia prime) When I connect my CRT to the notebook through VGA port, the CRT tells the notebook the max refresh rate for every resolution is 85 hertz. This is not real. With 1024x768 i can go 90 hz and with 800x600 I can go 110 hz. This also happened on windows, but the solution was simple: i just set the custom resolution in intel panel. Then if i open, for example, quake live, i can set the refresh rate to 90. But there is a difference between the windows driver and Xrandr. In windows, the 90 hz custom res is considered as an extension of the standard 1024x768. In fact, if I choose 1024x768 than, in the refresh slider, I get 60,75,85 and 90 hz. In Xrandr the custom resolution you add with --addmode is considered an entirely different res. So if the standard 1024 can only go 85 hz, and i add 90 hz, all the inferior refresh rates for 1024 are called "1024x768" and you can just make:

xrandr --output VGA1 --mode 1024x768 -r 85

but if you do

 xrandr --output VGA1 --mode 1024x768 -r 90

It doesn't work. You have to make:

  xrandr --output VGA1 --mode 1024x768_90.00

where 1024x768_90.00 is the name of the resolution you added. This leads to problems. For example, various games try to pick the highest refresh possible. So if it's 110, they still pick 85. And even if you force it through the game it still is 85. Isn't there a way to just add a refresh rate to an already existing mode? Also, Xrandr is having some strange behaviours.

For instance: I do

xrandr --output VGA1 --mode "1024x768_90.00"

And the refresh is set to 90 hz. But, if I open TeamSpeak, Warsow or Ubuntu SDK (and probably other apps i don't know about) the resolution is set back to 85 and LOCKED. This means that while those apps are running I can't have a custom rate. When I close them, i can again. This also happen when you start steam, but steam doesn't lock the framerate. Also, if I happen to use any xrandr command after having set new resolution, it returns 85 hz. To pick 90 hz again, I have to re-use the command for custom res THREE times. Exatly three times. AT the first twos both monitors turn black for a second and then back to 85 hz. The third time, only the crt turns black and goes 90 hz. This also happens with 800x600_110.00, but not three times. (I haven't counted but i'm sure it isn't three)

All this happens both in lightdm and gdm.

Has someone got any clues?

Also, isn't there any proprietary intel driver?

EDIT: I did some research, I would also like a way to disable EDID since all I've found didn't work.

  • You need to create a new mode with the specific resolution and refresh rate, see this answer – bain Jul 28 '14 at 0:42