1

It was working before but now it stopped working. Even in Ubuntu SDK I can't run my application directly to my device...though I'm not sure they are related. The error is:

Command: open "phablet@192.168.1.7" 22 Error: Disconnected: No supported authentication methods available (server sent: publickey) Error: Could not connect to server

My device is Nexus 7 2013(flo) with Ubuntu Touch 14.10 r153. I installed it through MultiRom and I actually did a fresh install but still no luck.

  • 1
    You can get ssh to be verbose by adding -v on the command line. The option can be given multiple times to increase verbosity. You will be able to see which authentication methods there are support at both ends. – jhilmer Jul 27 '14 at 17:01
  • There are/were steps to enable SSH, but they have changed recently. I will research further. Meantime, check out: lists.launchpad.net/ubuntu-phone (which is where the changes were announced. ) – david6 Jul 28 '14 at 7:58
  • I already enabled it before. I can't see anything from the mailing list about some changes on ssh. I tried this in both WinSCP on Windows and FileZill in Ubuntu so I think it's with Ubuntu TOuch or probably on my network/router? – user1173805 Jul 30 '14 at 15:18
  • 1
    Did you solve this? You needed to read: [Ubuntu-phone] Developer heads up ... change in ssh handling on the phone (on 23/05/14 02:51) Steps: create SSH key (on workstation), enable SSH on device, copy public key to device, connect. – david6 Aug 3 '14 at 2:32
  • I've read that but I still can't figure out how to login vie FileZilla/WinSCP. Same error occurs even if I already loaded the private key in the configuration of FileZilla. – user1173805 Aug 18 '14 at 14:07
0

I'm having the same issue, on the same tablet. I am currently using the developer channel, but not proposed. OS: 15.04 r2. It won't find my .pem key, however after running the commands below, I was able to get my computer to reject my tablet connecting to it via ssh. Please excuse typos

user@ubuntu:~$ adb shell

phablet@ubuntu-phablet:~$ android-gadaget-services enable ssh

phablet@ubuntu-phablet:~$ ssh...

I found out that the build in backup software, which I can't get to work, doesn't allow backup over ssh, if you use the adb interface. The adbd interface does nothing, but acts like it is performing some task.

  • Is this an answer to the question? I can't tell. – Seth Jun 8 '15 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.