0

Only my user is shown on greeter, guest is not, my wife is not. This is a system I reinstalled from 12.04-i386 to 14.04-amd64, reformating all but /home.
Even a user created from Trusty won't show on greeter.
The only way these 3 can log in is from my own system menu switch user feature.
I dug a bit and discovered I have the ~new ?~ AccountService thing installed, so that all tricks I found around about lightdm are now out of scope.
(please change the text about unity-greeter tag saying lightdm is underlying)

  • accountsservice was also used in 12.04. I don't think the tricks are dead yet – muru Jul 27 '14 at 10:43
  • Well the problem is that I do not have any /etc/lightdm/lightdm.conf file from which I could remove allow-guest=false (or add allow-guest=true, in the case missing allow-guest= line wouldn't be enough to restore the default behaviour). More, I read this in the lonesome /etc/lightdm/users.conf: # # User accounts configuration # # NOTE: If you have AccountsService installed on your system, then LightDM will # use this instead and these settings will be ignored # # minimum-uid = Minimum UID required to be shown in greeter # hidden-users = Users that are ... – useful Jul 27 '14 at 11:42
  • That's because lightdm is using a more flexible way of handling configuration. Have a look at this directory: /usr/share/lightdm/lightdm.conf.d (see askubuntu.com/questions/451950/…) – muru Jul 27 '14 at 11:44
1

Own answer to own question:
This ~bug~ was supplied by myself: the workaround was to download my glasses from the shelf to see that white font of users name on the ~white~ greeter from usr/share/backgrounds/Foggy_Forest_by_Jake_Stewart.jpg I choose myself running dconf-editor as lightdm user, is simply of poor contrast....
Sorry for the noise.

  • Best. Bug. Ever. – Sparhawk Jul 27 '14 at 15:13
  • 1
    No bounty for this? At least for my own answer ;-) – useful Jul 29 '14 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.