I have a laptop that someone gave me and it came with a PCMCIA card for the wireless connection. It is a D-Link Wireless WNA-1330 PCMCIA Card. When I installed Ubuntu 8.04, the wireless connectivity worked just fine without issue to my DSL router (that has a DHCP server on it). I was able to connect to the DSL router and surf the web.

I then ran the upgrade process to 10.04 in the Package/Update Manager. After the upgrade, the wireless card ceased to work. It would light up like it should, and it would see the network of wireless DSL routers in my neighborhood, but not let me connect with the WEP key.

When I checked the logs, I found it was timing out in trying to get an IP address for some reason. So, I read that I should set it to a static IP.

I set it to a static IP address and then it connected properly to the wireless router. The DSL router's network page also showed the connection. But then when I tried to surf the web, it wouldn't work. I tried pinging multiple hosts and all I could do was ping the DSL router I also had packet loss when pinging that router.

So, I changed the config to use Google's Public DNS ( and reconnected the wireless. This time, I could ping multiple sites on the web (with some packet loss) but could not browse them with the web browser. As well, I still cannot browse my router's management page on

What do you think is going on?


What Jorge Castro said is the next best thing to do after you have tried the latest available ath5k driver. There have been many updates to the driver since the kernel you are running. The following command will fetch the latest available ath5k driver compiled for your kernel (all latest wireless drivers for that matter):

sudo apt-get install linux-backports-modules-wireless-lucid-generic

Reboot after that and try connecting again. If issues persist - proceed as Jorge wrote.


This is a known problem for some Atheros chipsets. The driver was changed from madwifi to ath5k. While the former used to work perfectly, the latter fails for most people. Still it is default.

If lsmod | grep ath5k outputs anything, it might be your problem, too.

Here's what you can do to fix it: Delete /etc/modprobe.d/blacklist-ath_pci.conf and edit /etc/modprobe.d/backlist.conf to add

blacklist ath5k

to the end.

Now get the latest madwifi driver from http://snapshots.madwifi-project.org, unpack it, change into the newly created directory and run these lines

sudo apt-get install build-essential
make && sudo make install

Now reboot, run

sudo modprobe ath_pci

add the ath_pci to /etc/modules and reboot again. You should now be fully switched to the new driver.


First off I would stick with DHCP if that's how it's supposed to be working. Make sure the proprietary driver is enabled for the wireless adapter in System > Administration > Hardware Drivers. If it's still not working, try booting from a live ubuntu CD/USB and see if it works from there. If it does work there, you'll know that something is broken on your specific install; Maybe you have lingering ndiswrapper drivers or something else.


I had the same problem with a D-Link wireless adapter card when I upgraded to 10.04. Before the upgrade, things worked perfectly, but after, nothing would connect. I could see the SSIDs from wireless access points but couldn't connect.

The only way I was able to fix the issue was to install and configure Ndiswrapper (a tool that allows you to use the windows drivers for your wireless card). After I did that, everything works fine. I think that in the upgrade to 10.04, they found that the existing wireless drivers were conflicting with other libraries that the devs wanted in 10.04, so they decided to actually remove the drivers for these wireless cards in the installation/upgrade. I'm not 100% certain that this is what is wrong in your issue, but I would say definitely try Ndiswrapper to see if it fixes the issue. It sounds like a driver problem.

  • 1
    Can you provide more detailed information about how one might use ndiswrapper to solve this problem? – Eliah Kagan Jan 6 '13 at 2:33

I had the exact same problem with a Windows-PC till I found out, that my router somehow reset it's dhcp-configuration and only offered 20 dhc-leases instead of 70 (so there weren't enough leases for this computer, all the other computers worked fine). So you may want to check your router configuration first...


Try turn off ipv6 support altogether. It can mess up with your configuration.

  • 1
    I recommend expanding this answer to include information about how to disable IPv6 in Ubuntu. – Eliah Kagan Jan 6 '13 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.