2

After upgrading to 14.04. I ran into problems with opening .jar files. Double clicking on Client.jar doesn't open it. I tried right clicking and selecting both , OpenJDK Java 7 runtime and OpenJDK Java 6 runtime with no success.

Program runs fine from Eclipse and I can run it from terminal using java -jar Client.jar, but it's somewhat inconvenient.

How can I make it run by double-clicking the .jar file ?

P.S.

Double clicking on .jar worked fine on 12.04.

  • 1
    What about something from here?: askubuntu.com/questions/192914/… – jmunsch Jul 27 '14 at 1:06
  • Unfortunately none of those solutions worked. Launching .jar file using oracle's java has the same result as using openJDK, nothing happens. I tried creating .desktop file containing Exec=java -jar Client.jar (I also tried absolute address) but that didn't work either. Any other ideas ? – IlmarsL Jul 27 '14 at 8:56
  • Ok, I found a workaround. Launching it from bash script file works, but IMHO that's not a normal solution. I will appreciate any ideas on how to normally launch .jar files. – IlmarsL Jul 27 '14 at 9:05
  • 1
    possible duplicate of OpenJDK not working – A.B. Aug 16 '15 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.