1

I need to install the package texinfo version 4.11 that I downloaded from http://ftp.gnu.org/gnu/texinfo/ and unpacked (folder texinfo-4.11).

I already installed packages with the 'sudo apt-get install' command in the terminal. However, this does not work with 'sudo apt-get install texinfo-4.11' in the correct terminal location. The following error messages appear:

E: Unable to locate package texinfo-4.11

E: Couldn't find any package by regex 'texinfo-4.11'

  • Depending on your version of Ubuntu, it may not be available. You might have to compile from source. – muru Jul 26 '14 at 11:02
  • what is your ubuntu version? – user308564 Jul 26 '14 at 11:32
  • Ubuntu Precise has version 4.13 of texinfo, and Ubuntu Trusty has version 5.2.0. Are you sure you really need an older version? – saiarcot895 Jul 26 '14 at 11:39
  • There are errors when compiling the toolchain of my linux-control-unit. The manufacturer told me to use texinfo 4.11. I have ubuntu 13.10. – user250688 Jul 26 '14 at 14:57
1

You can't install software like that unless it's "packaged" for your system. You might want to see if someone has already created a package for Ubuntu. Otherwise, you'll have to compile and install manually. It isn't difficult, but also not as convenient as using an installer.

For basic installation instructions, look in texinfo-4.11.tar.bz/texinfo-4.11/INSTALL.

  • The compilation is delivering an error message: zulu@E131x-series:~/LCU1/texinfo-4.11$ ./configure bash: ./configure: Permission denied – user250688 Jul 26 '14 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.