3

I followed some online instructions for installing StarCraft II from Installing StarCraft II on Ubuntu 14.04 and then it was trying to download eurofixi.exe from an FTP site and not getting any response and having to repeat itself over and over with no success.

The game seems to have downloaded, but there's no executable file to run with Wine.

When I try to redownload the game to play it on Ubuntu 14.04, it gives me the option press play, and when I do this it loads the game in part, asks me to login to Battle.net (not giving me the option to play offline) and then goes pear-shaped.

In the last paragraph in the Installing StarCraft II on Ubuntu 14.04 tutorial it said.

If you encounter any other issues, check out the blog posts I mentioned previously for some tips. If those don't help you and Google fails you, head over to Ask Ubuntu and try to find help there.

  • 1
    Reviewers of this question can find a discussion about this question in Ask Ubuntu Meta here. – karel Feb 22 '16 at 3:01
3

StarCraft II can also be installed with another alternative method using the PlayOnLinux application from the Ubuntu Software Center.

There is a PlayOnLinux installer script for StarCraft II at the PlayOnLinux website. Click the arrow next to the Source code heading to unfold the source code of the PlayOnLinux installer script for StarCraft II.

Visit the Create a script for PlayOnLinux - Chapter 1: Getting to know Bash for instructions about how to run a PlayOnLinux installer script, including screenshots.

Executing your script

Save your script in gedit, right-click the script and select Properties -> Permissions tab -> put a check mark in the checkbox to the left of where it says Allow executing file as program, and then use the function Run a local script from the Tools menu of PlayOnLinux.

There is also a newer version of the PlayOnLinux installer script for StarCraft II that uses Wine 1.7 that is available on the same website. This update "fixes Battle.net crash and has better quality in-game". Wine 1.7 is not in the repositories for Ubuntu 14.04, however Wine 1.7 can be installed by adding this Launchpad PPA: ppa:ubuntu-wine/ppa to your software sources using the instructions found at that link. The version of Wine for Ubuntu 14.04 from this PPA is up-to-date enough (Wine 1.7.55) that the newer version of the PlayOnLinux installer script for StarCraft II can be used with it.

  • This hasn't worked yet, i'm in the process, but i'm grateful for your time mate. Thank you very much. – user277821 Jul 26 '14 at 3:54
  • guys this seems to have worked. – user277821 Jul 27 '14 at 0:40
  • When i run it through playonlinux, i click run, and it runs the game, however my mouse pointer disappears and it has trouble connecting to battle net. – user277821 Jul 27 '14 at 0:41
  • when i double click on the battlenet icon on the desktop, it comes up with an error and shuts down – user277821 Jul 27 '14 at 0:42
  • thanks for that. there is an updated one that i am now trying, which hasn't been approved by the team yet. I think you're right, it appears to be written for wine 1.7.19. I wish i didn't have to download the whole game again. 3rd time lucky i guess. – user277821 Jul 27 '14 at 1:14
1

I too have been working hard on hacking my way through this. I finally got the game to run when I figured out that my graphics card drivers weren't doing me any favors (literally) kill and or remove all your video card drivers and reinstall ones you're absolutely sure are correct. All the other workarounds that I tried wouldn't get me passed the launcher. For example going into wine to mess with dbhelp, running windowed at different resolutions, installing windows fonts and winetricks. After all of those it was my drivers. Something I thought was fine. When nothing works... start looking at what you only assumed was working.

For me, after installing drivers the game launches and plays, but there are block text bugs and blacked out portions of the screen. Now i'm trying all of those other things to get it working smoothly. I haven't tried play on linux yet and I'm going to check youtube. There was a good video on getting hearthstone/SC2 working. Now that my drivers are what I think they are, I might have success with their advice this time.

As far as finding the executale... It just kind of showed up under /program files/starcraft although I swear I looked there before. Keep digging.

1

I made it work. Here is how I did, you may need to adapt it.

  1. Fix the mesa package for the Blizzard launcher in case of black screen:

    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get dist-upgrade
    

    You might need to restart your X server for the changes to take effect.

    sudo restart lightdm
    
  2. Fix OpenGL drivers if it's still bugged:

    sudo add-apt-repository ppa:oibaf/graphics-drivers 
    sudo apt-get update
    sudo apt-get upgrade
    
  3. Create different overrides for different applications in wine settings (Configure Wine):

    • Create new -> choose Battle.net.exe -> libraries -> dbghelp (disabled) & msvcp100 (native, builtin)
  4. Start the Blizzard launcher, go to the game settings, check "launch 32 bits client" for Starcraft II.

  5. Start the game.

  • dist-upgrade upgrades your whole distribution. Beware. – Shahbaz Oct 10 '17 at 20:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.