I have been trying for the past couple of days to install Ubuntu 14.04 LTS on my laptop. I have been having problems left and right, but I finally ran into one that I can't figure out.

I put Ubuntu on a USB drive using UNetbootIn and booted (in CSM Mode - UEFI didn't work) into the live session. I ran the installer, which failed. I traced the problem to the hard drive, which had a magnet dropped on it over a year ago, and I reformatted it the long way. I ran the installer again, successfully. Then, I shut down, removed the USB drive, and started my computer (boot sequence: USB, HDD, ...) - and my computer tells me there is no bootable device. I force shut down my computer and reinserted the USB, booted into the live session, and ran Boot Repair. Still can't boot from the HDD.

Coming from a Windows background, I'm a newbie to all things Linux. I don't know what is causing my problem (the hard drive??), and don't know what to look for to help me find out.

Computer: 64 bit Toshiba Satellite C855D Laptop - came with Windows 8 preinstalled, but I removed that hard drive and put in the 500 GB one.

Hard Drive: 500 GB Toshiba MK5065GSX

Boot Repair URL (Maybe irrelevant - can't hurt): http://paste.ubuntu.com/7847577

I took a look at this page (https://help.ubuntu.com/community/UEFI) and thought that maybe my installation would work if I converted it to EFI mode (Ubuntu was installed in CSM Mode, because if I tried in UEFI mode, all I got after selecting an option on the boot menu was a blank/black screen). Would that make a difference? If so, how would I go about it? The page says I need to create an EFI partition, which I don't know how to do, and the requirements of mount point and flag mean nothing to me.

So, the short version of my question: Why won't my hard drive boot?

Update: I looked through the folders on my hard drive, and found that the "boot" and "sys" folders were empty! Like I said above, I am new to Linux/Ubuntu, but I assume that these folders are important. I ran the installer again, and now the "boot" folder has some stuff in it (grub folder and a few other files), but the "sys" folder is still empty. I think this is part if not all of my problem; what should I do about it?


Begin by going into your firmware setup utility. You typically do this by hitting Esc or a function key soon after turning on the computer (before GRUB or any Ubuntu boot messages appear). Unfortunately, details vary from one computer to another. Look for options related to boot mode and boot order. They're usually present on a page called "Boot." Ensure that BIOS/CSM/legacy support is enabled and ensure that the option to boot in BIOS/CSM/legacy mode from your hard disk is listed first in the boot order (or perhaps just after an option to boot from a CD-R or external USB drives generically). As with entering the firmware setup utility, the details vary greatly from one computer to another, so I can't be more precise about what you need to do.

If that doesn't work, you may need to try an EFI-mode installation. To do this, disable BIOS/CSM/legacy support in your firmware and boot your Ubuntu medium again. The "black screen" problem you encountered is common, but there are multiple causes and cures, so it's difficult to offer advice on this; but there are many questions and answers about it on this site, so start by browsing them. Don't worry too much about the EFI System Partition (ESP); the Ubuntu installer will create it automatically, unless you choose to partition manually.

  • I have already booted from my USB into the live session (in CSM boot mode) and installed Ubuntu to my hard drive, but I cannot boot from my hard drive, as it is not recognized as a bootable device. This answer (If your machine is CSM capable...) says that I should install in CSM mode (done) and then install grub-efi (not possible, because HDD won't boot).
    – Hatchet
    Jul 25 '14 at 16:00
  • Please re-read my answer; your comment doesn't change my advice. Installing grub-efi from BIOS/CSM/legacy mode is pointless -- or at the very least, it's sub-optimal, since it's impossible to fully and properly configure an EFI-mode boot loader from a BIOS-mode boot.
    – Rod Smith
    Jul 25 '14 at 18:45
  • The solution provided to my black screen problem/boot in EFI mode (link in previous comment) is to install grub-efi after CSM installation. Currently, I can't install in EFI mode because of the black screen problem.
    – Hatchet
    Jul 26 '14 at 1:04

Someone else may have a better answer, but do you know if the cmos battery is good? I recently had a similar problem. My cmos battery died, corrupted my bios and corrupted my boot files. I replaced said battery (cr2032 iirc), flashed the bios and formatted the drive.

  • UEFI firmware settings shows UTC time, not my local time. Is this normal? or do I need to replace my CMOS battery?
    – Hatchet
    Jul 25 '14 at 15:59
  • I honestly can't remember exactly how to tell. One of those batteries shouldn't cost you more than a couple of bucks, though. About the size of a nickel.
    – user237050
    Jul 25 '14 at 20:20

I'd get a copy of the Ultimate_Boot_CD (UBCD) to test all these things. See http:// ultimate.bootcd.com / ubcd version 5.0b12 or version 6 for new PCs using uEFI.

  • Even though I regard this answer as excessively vague I reviewed to leave it open because if the hard drive is possibly bad booting from a rescue CD would provide valuable information about it.
    – karel
    Sep 14 '18 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.