7

I'm trying to install Ubuntu 14.04 and it pops up a message saying:

The attempt to mount a file system with type vfat in SSI1(0,0,0),partition#1(sda)at/boot/efi failed

Can someone help please?

9

I had exactly the same problem today while installing Ubuntu Server on a UEFI machine. I received the following message:

The attempt to mount a file system with type vfat in SCSI1 (0,0,0), partition #2 (sda) at /boot/efi failed.

I created an EFI partition and a normal linux partition on a USB disk with the gdisk command. fdisk -l gave the following result for the disk:

Device       Start     End Sectors  Size Type
/dev/sdc1     2048 1050623 1048576  512M EFI System
/dev/sdc2  1050624 7831518 6780895  3.2G Linux filesystem

I then tried to mount the EFI partition with mount /dev/sdc1 /test/, but got the following response:

mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

I also tried mount -t vfat /dev/sdc1 /test/, but received the same response. I then formatted the EFI partition with mkfs.vfat /dev/sdc1. I then tried to mount the EFI partition again with mount /dev/sdc1 /test/. It worked perfectly.

My conclusion is therefore that the Ubuntu Server installer needs the EFI partition to be formatted when it tries to mount it to /boot/efi.

| improve this answer | |
  • Yep, encountered on ubuntu Server installer. Had to do mkfs.vfat -F 32 /dev/sdX1 (where "X" is my drive letter) before running installer again. Used a clonezilla usb flash disk to run mkfs.vfat, parted, etc – Donn Lee Sep 27 '18 at 0:45
  • Just to add, running that command and then booting into the installer again worked. I did not have any issues after this. – iopq May 15 '19 at 11:22
  • This helped on Kubuntu 18.04 too. – Michael Jun 27 '19 at 9:08
3

It's quite possible that you're seeing the effects of the Windows "Fast Startup" feature. This feature turns shutdowns into suspend-to-disk operations, which means that filesystems Windows has mounted (potentially including the EFI System Partition (ESP), which Ubuntu mounts at /boot/efi) may appear to be damaged in Ubuntu, and may not mount correctly. The solution is to disable Fast Startup in Windows. Note that the Windows Fast Startup feature is entirely separate from a feature that probably has a similar name in the firmware. The firmware feature is much less dangerous, although it will sometimes interfere with the computer's ability to boot from a USB flash drive, so it may need to be disabled to get the installer to boot.

| improve this answer | |
1

I reformatted my main partition as ext4.

Went into terminal with ctrl alt f1

Then formatted the partition

sudo mkfs -t ext4 /dev/sda2
| improve this answer | |
1

I had my first partition intended for the UEFI partition, and it was 100MB and type ext4. I got this error you got too, and I have secure boot and fast boot enabled in my BIOS/UEFI settings. My fix was to simply use gparted to delete that 100 MB partition and then when I did the Ubuntu 18 install I chose "Something else" and at that point dedicated the 100 MB partition for the UEFI boot stuff. It then formatted it for me and it worked!

Summary for me: don't have it pre-formatted as ext4. Instead, leave the empty 100 MB or so there for the UEFI boot partition, but let the Ubuntu installer partition and format it.

For all other partitions it was ok to have manually done them before-hand via gparted, and I did not have to turn off fast boot or secure boot in the BIOS/UEFI settings. Note, however, that I do NOT have Windows installed on this machine: it is Ubuntu 18 only.

| improve this answer | |
  • This worked for me -- format 100MB of the drive as EFI, and leave the rest as free space. – wordsforthewise Jan 17 '19 at 4:47
0

it sounds like you are getting a read error on either the hard disk or the cd, if you are confident the hard drive is fine then you can try burning another dvd and if that does not work it means you probably have a bad hard disk. If you can rule out either of those please report the bug on launchpad

| improve this answer | |
0

In the 'try ubuntu' desktop, open the command line and run the command : sudo mkfs.vfat /dev/X where X is the name of the efi partition. You can get the name of the partition using: sudo fdisk -l (the word 'efi' appears before the partition name).

| improve this answer | |
0

This happens apparently because the alternative server installer doesn't try to format the EFI partition for you. If you go BACK a couple times, then look at the bottom of the list of install actions you can drop to command line. Do so.

Check that your device is the one you think it is (mine was /Dev/sda1 for EFI and /Dev/sda2 for data). You can test mounting them in empty folders with: mkdir test mount /dev/sda1 test ls -al test umount test

The broken one won't mount at all. Fix it with: mkfs.fat16 /dev/sdX1 (substitute proper device here)

Then type 'exit' and continue the install.

| improve this answer | |
0

the solution is very simple..

  1. Go to GPARTED with Live Ubuntu.

  2. Look at Your Partition on Your USB Drive.

  3. There must be EXT 4 on some part on Your Partition.

  4. Format that part into FAT 32.

  5. Close the GPARTED, and Click Install Ubuntu icon on Your desktop.

-PROBLEM SOLVED. 🙂👍

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.