To turn on/off between the 2 cards, I used acpi_call and bumblebee as in this article: https://launchpad.net/~hybrid-graphics-linux

It works. However, from the first time I install a fresh Ubuntu and also now, I can't enable desktop visual effects. Even if turning on Nvidia card.

My laptop is Asus K53SV, core i7 Sandy Bridge. Don't know what the problem is?

Update: Intel integrated card info using lshw command:

         description: VGA compatible controller
         product: Sandy Bridge Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 09
         width: 64 bits
         clock: 33MHz
         capabilities: vga_controller bus_master cap_list rom
         configuration: driver=i915 latency=0
         resources: irq:45 memory:dd400000-dd7fffff memory:b0000000-bfffffff ioport:e000(size=64)

I had similar problem on ubuntu 11.04 with optimus. After fresh install there was nvidia driver (or nouveau - I dont rememeber) set in xorg.conf, but you cant directly use nvidia with optimus. Try to delete or rename the file /etc/X11/xorg.conf, or try to change the settings to use intel card. Bumblebee has its own config file for nvidia, so dont worry

| improve this answer | |
  • could u go into details on "change setting to use intel card" ? I've updated info about my Intel card above – Duc Tran Jun 29 '11 at 9:32

By default Ubuntu see that there is NVIDIA card, but no driver for it, so Unity is disabled. When I tried installing driver for NVIDIA, got black screen. Restarted in fail-safe graphics mode, removed driver, configured xorg.conf for Intel and now Unity works. Still haven't tried Bumblebee.

| improve this answer | |
  • I've installed Bumblebee, so now I had NVIDIA. Do I need to uninstall it and then configure xorg.conf? – Duc Tran Jun 29 '11 at 9:37

(My solution to your problem is at the end of this post)

I have got a sony vaio Z790 laptop, with an onboard Intel graphics card an a dedicated GeForce 9300M gs Nvidia card. I am working on Ubuntu Oneiric 11.10. When using windows I can only switch between them using a hardware switch, so I assume that my model does not support the Nvidia "Optimus" technology.

I still haven't managed to work with the Nvidia card and I am stuck with the integrated from intel. When I install the Nvidia drivers (either from their website or using jockey) and restart X, I get a black screen. I have fiddled a bit with the xorg.cong file (adding various options such as a custom monitor EDID (CustomEDID option), specifying explicitly where the Nvidia card is connected (using the BusID option) and others, but the furthest I have got is to get a small white window on the top left of a totally black screen.

Back to your problem: From what I have experienced, my understanding is that once you install an nvidia driver your whole OpenGL configuration is messed-up. Even if you uninstall the drivers afterwards using nvidia-uninstall, still you wont get the 3D unity interface when you restart.

I have written the following little script which combines things I have read in varius forums, which always restores the intel configuration after an unsuccessful attempt to install some kind of driver to get my nVidia card working:

(note the this might mess-up your bumblebee configuration - I haven't looked a lot into bumblebee yet)

sudo apt-get purge nvidia*
sudo apt-get install --reinstall xserver-xorg-video-intel  libgl1-mesa-glx:amd64 libgl1-mesa-glx:i386 libgl1-mesa-dri:amd64 libgl1-mesa-dri:i386 xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
sudo update-alternatives --remove gl_conf /usr/lib/nvidia-current/ld.so.conf
sudo rm /etc/X11/xorg.conf
sudo stop lightdm
sudo start lightdm

Instead of typing the commands one by one, you can 1. copy this script to a new file 2. save it as you wish (e.g. "fix.run") 3. open a terminal, navigate to the directory where your script is 4. execute the command "sh fix.run" (replace fix.run with your filename)

(Note that I have no idea if the last 2 commands will work in earlier versions of ubuntu - I am new to linux. In case they don't, just find out how to restart your X server, or try hitting ctrl+alt+backspace or ctrl+print screen+k). Hopefully you will fall back on your intel configuration with the nouveau drivers and after a few seconds you will be back on unity 3D.

Hope this helps, Nikos

| improve this answer | |
  • 1
    At installation time, Bumblebee fixes the paths. The commands are only necessary after installing Ironhide or a very old version of Bumblebee (talking about the one from mj-casalogic a.k.a. MrMEEE). Basically, you need to configure the gl_conf paths to use Mesa. Removing nvidia* is optional, reinstalling the mentioned packages is superfluous as is dpkg-reconfigure xserver-xorg. update-alternatives --remove is not necessary when removing nvidia-current. – Lekensteyn Mar 20 '12 at 16:28
  • Removing /etc/X11/xorg.conf is necessary if you've ran nvidia-xconfig before. If you do not have nvidia-current installed, you're done now. Relogin or reboot to get 3D acceleration back. Otherwise, you need to configure gl_conf to use Mesa as described in askubuntu.com/a/107746/6969 – Lekensteyn Mar 20 '12 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.