0

I try and install skype 4.2 from the Synaptic package center and it says installed but when i try to run it nothing happens. I've tried both the Skype:i386 and the regular Skype with the binary files installed. I tried reinstalling, installing through terminal, installing through software center, and it just never runs.

Output below is from when i ran dpkg -l skype

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  skype          4.2.0.11-0ub i386         client for Skype VOIP and instant
  • What happened when you just run skype? – Tim Jul 24 '14 at 21:17
  • nothing...when i put the icon in the launcher and open from there it blinks like other applications do before they open and it then it just stops...then i go check the processes and skype isn't running – user307105 Jul 25 '14 at 0:03
  • 1
    What error message do you get if you run skype from a terminal window? – Gunnar Hjalmarsson Jul 25 '14 at 1:34
  • If I type Skype into the Terminal I get this reply: skype: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory – user307105 Jul 25 '14 at 22:15
0

Try starting Skype from a terminal window with this command:

LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype

and let us know what happened.

Edit:

Since it worked, this is one way to fix the start of Skype more persistently:

  • Create a file named ~/bin/skype
  • Give it this content:

    #!/bin/sh exec env LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/bin/skype "$@"

  • Make it executable using chmod +x ~/bin/skype

  • Log out and log in again
  • It worked and logged in fine finally, but I can still only run skype using that command. Is there a way to fix that now? – user307105 Jul 26 '14 at 18:11
  • @user307105: Yes, see my edited answer. – Gunnar Hjalmarsson Jul 26 '14 at 20:00
  • I created a file in both /usr/bin and /bin named Skype, put that content then saved it; then ran the chmod +x command on terminal. i then logged out and back in and tried again and now when i run skype from terminal it says directory not found, even though i know its there. and when i run the preload command it now gives me ERROR: ld.so: object '/usr/lib/i386-linux-gnu/mesa/libGL.so.1' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored. – user307105 Jul 26 '14 at 21:30
  • @user307105: That's not good. I meant that you should create it in your home directory, i.e. /home/[yourname]/bin/skype. I suggest you do so, remove the file from /bin and reinstall skype (if you created a text file as /usr/bin/skype, you overwrote the actual skype program...). – Gunnar Hjalmarsson Jul 26 '14 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.