How to enable SHMconfig on Ubuntu 11.04? I'm trying to change touchpad's configuration on run-time, but can't because it needs for SHMconfig to be enabled, how can I do that?

2 Answers 2


I think you can add Option "SHMConfig" "true to /usr/share/X11/xorg.conf.d/50-synaptics.conf which may look like this:

Section "InputClass"
     Identifier "touchpad catchall"
     Driver "synaptics"
     MatchIsTouchpad "on"
     MatchDevicePath "/dev/input/event*"
           Option "TapButton1" "1"
           Option "TapButton2" "2"
           Option "TapButton3" "3"
           Option "SHMConfig"  "true"

Or temporarily you can do synclient SHMConfig=1 in terminal to check the behaviour you want.

  • 2
    synclient SHMConfig=1 is not working in 13.10 Oct 20, 2013 at 16:01

Is this for the synaptics driver?

It's been a while since I've needed this as I don't have a laptop that requires it, but under previous versions you could do this with a HAL policy:

First, create the file


with the following contents:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
     <match key="input.x11_driver" contains="synaptics">
         <merge key="input.x11_options.SHMConfig" type="string">On</merge>
         <merge key="input.x11_options.MaxTapTime" type="string">0</merge>

(I've added MaxTapTime=0 to turn off tap-to-click)

Restart the haldaemon, then restart X11.

After that, gsynaptics should be able to communicate via SHMConfig.

  • I can't find the /etc/hal/fdi/policy/11-synaptics-options.fdi I think that the migration from hal to Udev have purged them.
    – ashams
    Jun 30, 2011 at 11:35
  • 1
    <del>You need to create the file, like it says.</del> ah, nevermind. must be an old directory on my machine leftover from the upgrade.
    – Eric
    Jul 4, 2011 at 8:56
  • How does one restart the haldaemon? I can't seem to find this. If it's not installed, then will these instructions not work for my 11.04 Sony Vaio VPCF136FM?
    – jmort253
    Aug 28, 2011 at 4:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.