Could you help me with hell of a weird issue? I use Intellij IDEA 13 on Ubuntu 14.04, and from time to time my keyboard completely (yep, completely, it's not about shortcuts) locks in IDEA. I still can do anything I want in IDEA with my mouse, also I can use the keyboard everywhere else except IDEA. And it can be fixed only by restarting IDEA so far.

Can anybody give a hint, please?

  • Can it be that your keyboard is simply being captured by some field inside IntelliJ? Is it a random thing or does something specific trigger it?
    – Ruraj
    Jul 24, 2014 at 7:08
  • I don't think some field can capture keyboard like that, but I'll check it more precisely next time. And it seems to be random thing. Jul 24, 2014 at 11:10
  • 4
    My collegue and I are experiencing precisely the same thing (same OS and IntelliJ 13.1.4). I have to restart IntelliJ once every few hours (I'm able to use Alt-F4, though) - extremely annoying. I also find it to happen completely randomly. Last time I was in the middle of editing an HTML file. Not while pressing a shortcut.
    – bisgardo
    Jul 24, 2014 at 12:28
  • I had two instances of IntelliJ running and they both froze. Don't know if it's relevant, but when I close the IDE, detaching a running application server normally takes very short time. After a freeze happens, I have to cancel that because it doesn't seem to finish.
    – bisgardo
    Jul 24, 2014 at 12:34
  • 3
    This is a Java issue that effects other Java Swing GUI's including SOAP UI. "ibus-daemon -rd" fixes the issue as well
    – rjdkolb
    Feb 9, 2016 at 12:02

4 Answers 4


There is a an open issue in jetbrains youtrack for intellij idea that recommend two solutions:

  1. Keyboard input may be unlocked by restarting IBus daemon from a console:

    ibus-daemon -rd
  2. IBus can be disabled for IDEA by unsetting env. variable XMODIFIERS, but ability to input national characters in IDEA will be lost:

    XMODIFIERS="" idea.sh

I have used the second one and fixed my problem.

  • 27
    > "ibus-daemon -rd" from a console. That worked! Great-great thanks!) Oct 23, 2014 at 8:37
  • 6
    6 months later, Option 1 is no longer recommended as it may cause JVM crash :/
    – mike
    May 1, 2015 at 14:57
  • 2
    What do you mean national characters, @Mike, it worked for me today June the 2th Jun 2, 2015 at 9:05
  • 24
    "ibus-daemon -rd" - I'm seriously considering to tattoo this on my arm. Jun 17, 2015 at 13:24
  • 4
    Last update on the issue (Jun 17 2015) recommends to export IBUS_ENABLE_SYNC_MODE=1 Sep 23, 2015 at 12:01

I was able to solve it with what I found here that is basically adding export XMODIFIERS="" on idea.sh

  1. Temporary solution: simply execute ibus-daemon -rd on the terminal.
  2. Permanent solution: the 01 Oct 2015 update on the issue recommends to:

Either upgrade IBus to version 1.5.11 or add export IBUS_ENABLE_SYNC_MODE=1 to your ~/.profile, then restart a session.

Alternatively, you can turn off IBus at System Settings | Language Support | Keyboard input method.

IDEA 15 will show a warning if an incompatible version of IBus is in use.


I've tried this out and its working so far but I'll update if it freezes up again. I've seen a suggestion on youtrack that suggests to turn off iBus which seems to interfere particularly because of it's use of the ctrl + space shortcut to change language settings. You can do that by going to:

language support > keyboard input method system > none

enter image description here

**** UPDATE *****

After running it for a while this technique still didn't work as I kept freezing. I guess for now I'll stick to the following workaround to restart ibus which is a bit inconvenient but what can you do.

go into terminal


ibus-daemon -rd
  • thanks, ibus-daemon -rd is what I was looking for.
    – Lambart
    Apr 21, 2016 at 19:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .