I got ubuntu 14.04 on hp pavalion g6 with an amd apu a6 llano which has a stock frequency of 1500mhz and is capable of boosting to 2400mhz.
But on my system it's turbo boost feature is not working.


I had a similar issue on my dell inpiron, and solved it though several steps. There are a few needed applications, and an edit to /etc/rc.local

Install indicator-cpufreq, cpufrequtils: Open a terminal window ctrl+alt+t and enter

sudo apt-get install indicator-cpufreq
sudo apt-get install cpufreq-utils

These will help monitor your cpu

The edit to rc.local tells Ubuntu to ignore some settings in your bios, and will need to be customized for the number of CPU's that you have.

sudo nano /etc/rc.local

Before the line which says "exit 0", enter the lines

echo 1 > /sys/module/processor/parameters/ignore_ppc

for x in /sys/devices/system/cpu/cpu[0-3]/cpufreq/;do 
  echo 2501000 > $x/scaling_max_freq

replace "2501000" with the maximum frequency of your CPU, in kHz (it should be 2401000) - the extra '1' in the frequency indicates turbo mode

You can determine the max frequency your system supports by

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies

Reboot, and everything should be good.

  • it's not working dude I tried it but no result. – Vishvendra Singh Jul 23 '14 at 14:44
  • Can you add to your question the output of cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies and cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq and cat /etc/rc.local – Charles Green Jul 23 '14 at 15:01
  • ok dude i don't have enough privilege to post image so I am posting a link to image dropbox.com/s/w4af80i46bli8b7/… – Vishvendra Singh Jul 23 '14 at 15:09
  • K - it looks like Ubuntu is detecting max frequency as 1.5 Ghz. We've reached the limit of my ability to do anything - my system always listed higher available frequencies, but would not access them before. – Charles Green Jul 23 '14 at 15:12
  • I don't mean to be rude, Charles, but you sound like you're not familiar with the details of @Jarvish 's case. – Run CMD Jul 23 '14 at 15:40

I found out that turbo core is working to cpufreq just doesn't show that to see that it's working use these command

sudo modprobe -v msr
sudo cpufreq-aperf

it's shows average cpu frequencies over period of time and don't forget using performance cpu governor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.