-1

At work i have to connect to a guest wireless network. This usually requires me to acces 1.1.1.1/login.html to complete the connection using a set username and password that changes every week. I see the guest wi-fi on the list of available networks, I click on it, trys to connect and never does. Eventually it says offline again. Never bringing me to login page listed above. Any ideas.

BTW - I was able to login to my private wi-fi network at home with no problems. I also tried it at Starbucks today and had no issues.

I also tried to login to this Guest Wi-Fi using a windows machine and had no issues either.

Not sure what to check since I an ubuntu virgin (only 3 days old). i did look in the System Settings>Software&updates>additional drivers> and noticed a was using the following:

Broadcom 802.11 Linux STA Wireless driver source from bcmwl-kernel-source (proprietary) was selected. No other options were available under wirelessbg/n controller.

=============================================== RESOLUTION:

LP#1010931 14e4:4727 [Dell Vostro 3555] Broadcom BCM4313 5GHz doesn't work but 2.4GHz does

The root cause is the card is single-band only, so it would never broadcast at 5GHz. To fix the 14e4:4727 on Ubuntu Trusty 14.04, uses brcmsmac :

sudo apt-get purge bcmwl-kernel-source sudo apt-get install linux-firmware-nonfree Then you need to blacklist b43 and wl driver like this:

echo "blacklist b43" | sudo tee -a /etc/modprobe.d/blacklist.conf echo "blacklist wl" | sudo tee -a /etc/modprobe.d/blacklist.conf

sudo modprobe -r b43 wl brcmsmac sudo modprobe brcmsmac echo "brcmsmac" | sudo tee -a /etc/modules

  • have you tried setting your browser to the url 1.1.1.1/login.html before you login in case it is a problem with automatically re-directing you to this page? – mchid Jul 23 '14 at 5:16
  • Hi & welcome to AU. I'm not sure whether this is the case, but try to look into Can't connect to wireless 13.10 & do accordingly, then try connecting. If it helps, please comment. – AzkerM Jul 23 '14 at 5:17
  • Yes, I actually pulled up the page and kept refreshing it while it was trying to connect and never came up. Here are some info on my card in case you guys need it: BCM4313 802.11bgn wireless Network Adapter [14e4:4727] (rev01) – Heinz Seijas Jul 23 '14 at 5:23
  • I did try the following as well and this did not work: cd /etc/NetworkManager/system-connections # locate all the stored network profiles ls # list down the network profiles sudo rm you_access_point_name – Heinz Seijas Jul 23 '14 at 5:40
  • well did you exactly removed your AP profile by replacing its original SSID name to you_access_point_name?? – AzkerM Jul 23 '14 at 5:42
0

Try the following commands in a terminal

sudo iwconfig wlan0 retry 15

and see if that doesn't help.

This sets your retry limit from the default of 7 to 15. The default is set at 7 to increase battery time and to use less power but in cases of public wifi and weak signals, this can cause issues, especially when trying to connect to the network. When your computer sends a signal that is not answered, it will retry instead of giving up so easily.

  • Seems to be keeping the connection now(sporadically) but auth page (1.1.1.1/fs/customwebauth/login.html) page never loads. I went to it manually but it doesnt come up (unable to connect) – Heinz Seijas Jul 23 '14 at 6:34
  • @HeinzSeijas It may be rejecting you because of your mac address. I will post a solution above. – mchid Jul 23 '14 at 6:41
  • 1
    posted it the fix on my question section since I was not able to close this due to restrictions (new user) – Heinz Seijas Jul 23 '14 at 6:51
  • @HeinzSeijas you should be able to post that as an answer ( you can answer your own question and accept it ) – mchid Jul 23 '14 at 6:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.