0

I was bored recently so I decided to download and install drivers from ASUS site. My motherboard is Asus P5K. After downloading the drivers, I messed up the installation somehow (don't remember the details) and now I don't have sound at all!

I'm new to Ubuntu and I don't have a clue how driver setup works. Can you tell me how to bring back the old drivers or how to install this driver? And the first driver worked perfectly, but I was curious about the new driver so I messed up :(

P.S, Ubuntu 14.4

  • Without the exact details of what you did, it is very hard to tell you how to reverse it. Which page did you download this driver from? The Asus site only has audio drivers for your motherboard for Windows. It would probably be quicker and easier for you to just re-install Ubuntu. – bain Jul 22 '14 at 21:25
  • @bain that's what usually comes to mind, but I looked and found drivers, but I didn't like what I saw. – LiveWireBT Jul 22 '14 at 22:23
0

If you installed the audio drivers, you most likely installed the ALSA package. When ALSA installs, it is set to "global Mute" and you have to open ALSA and take it off mute before your audio can be used. In a terminal type

alsamixer

if command not found, type

sudo apt-get update
sudo apt-get install alsa-utils

and then

alsamixer

and take it off mute.

  • It's not on mute, everything is on 100 except for front mic... I need help to install the driver again – Dario Jul 22 '14 at 19:50
  • @Dario okay, what's the output of lspci -v say about your "Audio device" ? This will display what device you are using so we can determine the missing driver and go from there. – mchid Jul 22 '14 at 20:24
0

the first driver worked perfectly, but I was curious about the new driver

I don't see a new driver on the support page.

Possible solutions:

  • Restore from your last system backup.
  • Uninstall the old drivers from the ASUS site, e.g. run make uninstall where you ran make install in the instructions to install the drivers (have a look at the corresponding makefiles if uninstall fails), reinstall the corresponsing alsa packages from the repository and probably run update-initramfs -k all -u to be sure that there are no old drivers in the initramfs image.

Remember:

  • If it ain't broke, don't fix it.
  • Have up to date backups. Verify them.
  • Be careful, especially when using root permissions.
    • When installing software/drivers manually: read changelogs and release notes; verify version numbers, timestamps and hashes; read the installation instructions entirely before attempting to install.

tl;dr: Use your brain! Being a beginner is not a valid excuse for being lazy and sloppy.

  • When talking about the "new driver", I'm talking about the one from the ASUS site... I managed to fix the problem – Dario Jul 25 '14 at 10:26
  • @Dario Then please mark an answer as accepted or provide your own. – LiveWireBT Jul 25 '14 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.