9

I set the Super button to open whisker menu.

But, for example when I press Super + F it also opens.

How can I fix this problem?

  • Would love to solve this too, it's a shortcut I rely on from so many years on Windows and the Super key is a great one to set custom shortcuts to because it's usually left alone by other applications. I've seen this same issue on various desktops on Linux Mint. The solution is to be able to bind an event to when the Super key is released rather than pressed and think that's how it was done in Mint+XFCE. But I have no idea about Xubuntu. – batfastad Sep 3 '14 at 23:01
  • i can't comment, i should, but not enough points. but it must be possible since in ubuntu you can press the windows key to search for program, but use windows key + number to launch number application on the dock – stetim94 Dec 3 '14 at 13:24
3

Sorry i am a bit late but you can go to xfce setting manager ->keyboard ->shortcuts

image

1

First of all Whisker menu is a third party application not developed by XFCE team or Xubuntu. And coming to your issue, Whisker Menu doesn't have ability to bind shortcuts to "Release". That means when you try to initiate other shortcuts involving Super Key, then Whisker Menu also pops up. Hopefully developer of this menu integrates this ability. However there is a workaround though. Create shell script to launch both application and whisker menu. Then bind shortcuts to that script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.