3

I just installed XUbuntu on my Vmware Workstation. After I saw, that I can't change display settings (resolution), I try to install VMware Tools. But - after I run vmware-install.pl, I get a message:

The following VMware kernel modules have been found on your system that were 
not installed by the VMware Installer. Please remove them then run this
installer again.

vmci
Execution aborted.

What can I do?

4

This is what I did for Ubuntu 16.04:

sudo apt remove --auto-remove open-vm-tools
sudo apt purge open-vm-tools

It complained about not being able to delete a directory since it is not empty so I manually removed one file that resides in that directory using:

sudo rm /etc/vmware-tools/scripts/vmware/network.old.0

And now you can run vmware-install.pl again.

  • I had to completely get rid of the /etc/vmware-tools folder, then I could use vmware-install.sh ... – firepol May 2 '17 at 18:35
  • This procedure worked for 17.04 too. @firepol, I left that folder there and it seemed to work fine. – Mark Beckwith Sep 13 '17 at 15:02
0

You're almost there. You need to run the command with the ./, so just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo ./vmware-install.pl

Also see if open-vm-tools are installed. Remove with the below command

sudo apt-get remove open-vm-tools

As a last resort, delete the .vmware folder from your home folder, reboot your machine, and try installing vmware tools again.

Edit

Try the following command: sudo /usr/bin/vmware-config.pl

  • I did ... before (and now again). Now I even reinstall the system (with disk format), but the same problem again. – JanezKranjski Jul 22 '14 at 9:50
  • Try what I've added in my answer. Let me know if it works. – Mitch Jul 22 '14 at 9:54
  • Thans for help. I tried remove open-vm-tools, but it wasn't installed. The (hidden) .vmware folder also wasn't there. – JanezKranjski Jul 22 '14 at 10:04
  • What version vmware workstation are you trying to install, and Ubuntu release? – Mitch Jul 22 '14 at 10:15
  • XUbuntu 14.04 64-bit and VMware Server 2.0.2 – JanezKranjski Jul 23 '14 at 3:16

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.