7

I'm completely new to this. I am running Ubuntu 14.04 on a new Dell desktop. I am having a problem with Xorg and compiz using >60% of a CPU. I think this is because my graphics driver is not being recognized, and so software is being used as the accelerator as opposed to the card.

My card is Intel Xeon E3-1200 v3/4th Gen Core. Please take a look at the output below and ask me if I am leaving out important information. I'd be grateful for any advice. I think the telling lines are the "Not software rendered: no," the "(EE) Failed to load module "modesetting" (module does not exist, 0)," and the "AIGLX: Screen 0 is not DRI2 capable; AIGLX: reverting to software rendering" are the informative lines.

I have updated the Intel driver.

uname -a

Linux xxx 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

lshw -c video

*-display UNCLAIMED     
       description: VGA compatible controller
       product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)

Output of: /usr/lib/nux/unity_support_test -p

OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)
OpenGL version string:  2.1 Mesa 10.1.3


Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes


Unity 3D supported:       no

Relevant portions of my Xorg.0.log:

[    10.871] Loading extension GLX
[    10.871] (==) Matched intel as autoconfigured driver 0
[    10.871] (==) Matched modesetting as autoconfigured driver 1
[    10.871] (==) Matched fbdev as autoconfigured driver 2
[    10.871] (==) Matched vesa as autoconfigured driver 3
[    10.871] (==) Assigned the driver to the xf86ConfigLayout
[    10.871] (II) LoadModule: "intel"
[    10.871] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    10.873] (II) Module intel: vendor="X.Org Foundation"
[    10.873]     compiled for 1.15.0, module version = 2.99.910
[    10.873]     Module class: X.Org Video Driver
[    10.873]     ABI class: X.Org Video Driver, version 15.0
[    10.873] (II) LoadModule: "modesetting"
[    10.873] (WW) Warning, couldn't open module modesetting
[    10.873] (II) UnloadModule: "modesetting"
[    10.873] (II) Unloading modesetting
[    10.873] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    10.873] (II) LoadModule: "fbdev"
[    10.873] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    10.873] (II) Module fbdev: vendor="X.Org Foundation"
[    10.873]     compiled for 1.15.0, module version = 0.4.4
[    10.873]     Module class: X.Org Video Driver
[    10.873]     ABI class: X.Org Video Driver, version 15.0
[    10.873] (II) LoadModule: "vesa"
[    10.873] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    10.873] (II) Module vesa: vendor="X.Org Foundation"
[    10.873]     compiled for 1.15.0, module version = 2.3.3
[    10.873]     Module class: X.Org Video Driver
[    10.873]     ABI class: X.Org Video Driver, version 15.0
[    10.873] (==) Matched intel as autoconfigured driver 0
[    10.873] (==) Matched modesetting as autoconfigured driver 1
[    10.873] (==) Matched fbdev as autoconfigured driver 2
[    10.873] (==) Matched vesa as autoconfigured driver 3
[    10.873] (==) Assigned the driver to the xf86ConfigLayout
[    10.873] (II) LoadModule: "intel"
[    10.874] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    10.874] (II) Module intel: vendor="X.Org Foundation"
[    10.874]     compiled for 1.15.0, module version = 2.99.910
[    10.874]     Module class: X.Org Video Driver
[    10.874]     ABI class: X.Org Video Driver, version 15.0
[    10.874] (II) UnloadModule: "intel"
[    10.874] (II) Unloading intel
[    10.874] (II) Failed to load module "intel" (already loaded, 32548)
[    10.874] (II) LoadModule: "modesetting"
[    10.874] (WW) Warning, couldn't open module modesetting
[    10.874] (II) UnloadModule: "modesetting"
[    10.874] (II) Unloading modesetting
[    10.874] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    10.874] (II) LoadModule: "fbdev"
[    10.874] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    10.874] (II) Module fbdev: vendor="X.Org Foundation"
[    10.874]     compiled for 1.15.0, module version = 0.4.4
[    10.874]     Module class: X.Org Video Driver
[    10.874]     ABI class: X.Org Video Driver, version 15.0
[    10.874] (II) UnloadModule: "fbdev"
[    10.874] (II) Unloading fbdev
[    10.874] (II) Failed to load module "fbdev" (already loaded, 0)
[    10.874] (II) LoadModule: "vesa"
[    10.874] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    10.874] (II) Module vesa: vendor="X.Org Foundation"
[    10.874]     compiled for 1.15.0, module version = 2.3.3
[    10.874]     Module class: X.Org Video Driver
[    10.874]     ABI class: X.Org Video Driver, version 15.0
[    10.874] (II) UnloadModule: "vesa"
[    10.874] (II) Unloading vesa
[    10.874] (II) Failed to load module "vesa" (already loaded, 0)
[    10.874] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    10.875] (II) intel: Driver for Intel(R) HD Graphics: 2000-5000
[    10.875] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100
[    10.875] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200
[    10.875] (II) FBDEV: driver for framebuffer: fbdev
[    10.875] (II) VESA: driver for VESA chipsets: vesa
[    10.875] (++) using VT number 7
[    10.881] (II) Loading sub module "fbdevhw"
[    10.881] (II) LoadModule: "fbdevhw"
[    10.881] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    10.881] (II) Module fbdevhw: vendor="X.Org Foundation"
[    10.881]     compiled for 1.15.1, module version = 0.0.2
[    10.881]     ABI class: X.Org Video Driver, version 15.0
[    10.881] (**) FBDEV(0): claimed PCI slot 0@0:2:0
[    10.881] (II) FBDEV(0): using default device
[    10.881] (WW) Falling back to old probe method for vesa
[    10.881] (II) FBDEV(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[    10.881] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
[    10.881] (==) FBDEV(0): RGB weight 888
[    10.881] (==) FBDEV(0): Default visual is TrueColor
[    10.881] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
[    10.881] (II) FBDEV(0): hardware: VESA VGA (video memory: 9024kB)
[    10.881] (II) FBDEV(0): checking modes against framebuffer device...
[    10.881] (II) FBDEV(0): checking modes against monitor...
[    10.881] (--) FBDEV(0): Virtual size is 1920x1200 (pitch 1920)
[    10.881] (**) FBDEV(0):  Built-in mode "current": 230.4 MHz, 94.7 kHz, 77.4 Hz
[    10.881] (II) FBDEV(0): Modeline "current"x0.0  230.41  1920 1952 2192 2432  1200 1204 1208 1224 -hsync -vsync -csync (94.7 kHz b)
[    10.881] (==) FBDEV(0): DPI set to (96, 96)
[    10.881] (II) Loading sub module "fb"
[    10.881] (II) LoadModule: "fb"
[    10.881] (II) Loading /usr/lib/xorg/modules/libfb.so
[    10.881] (II) Module fb: vendor="X.Org Foundation"
[    10.881]     compiled for 1.15.1, module version = 1.0.0
[    10.881]     ABI class: X.Org ANSI C Emulation, version 0.4
[    10.881] (**) FBDEV(0): using shadow framebuffer
[    10.881] (II) Loading sub module "shadow"
[    10.881] (II) LoadModule: "shadow"
[    10.881] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    10.881] (II) Module shadow: vendor="X.Org Foundation"
[    10.881]     compiled for 1.15.1, module version = 1.1.0
[    10.881]     ABI class: X.Org ANSI C Emulation, version 0.4
[    10.881] (II) UnloadModule: "vesa"
[    10.881] (II) Unloading vesa
[    10.881] (==) Depth 24 pixmap format is 32 bpp
[    10.881] (EE) FBDEV(0): FBIOBLANK: Invalid argument
[    10.881] (==) FBDEV(0): Backing store enabled
[    10.882] (==) FBDEV(0): DPMS enabled
[    10.882] (==) RandR enabled
[    10.884] (II) SELinux: Disabled on system
[    10.885] (II) AIGLX: Screen 0 is not DRI2 capable
[    10.885] (EE) AIGLX: reverting to software rendering
[    10.903] (II) AIGLX: Loaded and initialized swrast
[    10.903] (II) GLX: Initialized DRISWRAST GL provider for screen 0

Tuesday update: This issue continues. Other anomalies I've noted that might be related:

My monitor is detected as a "built in display" and the resolution cannot be changed. I figure this must be related. (I have an external monitor.)

Output of xrandr --verbose:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1200, current 1920 x 1200, maximum 1920 x 1200
default connected primary 1920x1200+0+0 (0x17f) normal (normal) 0mm x 0mm
Identifier: 0x17e
Timestamp:  173701
Subpixel:   unknown
Clones:    
CRTC:       0
CRTCs:      0
Transform:  1.000000 0.000000 0.000000
           0.000000 1.000000 0.000000
           0.000000 0.000000 1.000000
          filter: 
  1920x1200 (0x17f)  177.4MHz *current
        h: width  1920 start    0 end    0 total 1920 skew    0 clock   92.4KHz
        v: height 1200 start    0 end    0 total 1200           clock   77.0Hz

Wednesday update: I found a "Driver Device Manager" tool of Intel. Installed it. It properly lists my graphics hardware as Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller, but the activated driver is the frambuffer display driver (fbdev). It gives me the option to, instead, activate the intel driver (version 2:2.99:910-0ubuntu1) with "Recommended" in the description. That's all fine and dandy.

Checked "activate" for the correct driver. It requested a computer restart. Said sure and restarted..... No dice. Same result. Reverting to Gallium 0.4.

Any thoughts? Where is my problem? Is it in the hardware, or in the driver, or somewhere in some other ubuntu file?

3

You could try installing the intel-linux-graphics-installer. I have personally used it with various sandybridge cards, it won't hurt to give it a try.

If you don't have gdebi I recommend installing deb packages with gdebi to fix dependency issues that may arrise:

sudo apt-get update && sudo apt-get install gdebi

now download the installer from 01.org

wget https://download.01.org/gfx/ubuntu/14.04/main/pool/main/i/intel-linux-graphics-installer/intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb

make the deb executable and install using gdebi:

sudo chmod +x intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb
sudo gdebi intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb

Now, to run the installer just use the following command:

intel-linux-graphics-installer

reboot for your changes to take effect.

More info about Intel Open Source Technologies can be found here

https://01.org

and here

https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-1.0.6-linux

  • after running the intel-linux-graphics-installerit says that my distribution is not supported. – NKN May 6 '15 at 9:59
  • 2
    @NKN I haven't tested it on 14.04 but I did the following on debian jessie which also uses x11 and not mir and have had no compatibility issues in fact it fixed the way mp4 videos used to get distorted after playing through the first time when set to a loop on tumblr. First, run the following command to install the hardware enablement stack: sudo apt-get install --install-recommends dkms linux-tools-generic-lts-utopic linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic – mchid May 6 '15 at 23:14
  • 2
    @NKN Now, go ahead and reboot and on the grub menu select advanced options and then select kernel 3.16 from the list of kernels and run the following commands in an open terminal after you boot the system: sudo nano /etc/lsb-release , change 14.04 to 14.10 and change trusty to utopic. Press CTRL+o to save the file and CTRL+x to exit. Next, run this command to download the newest version from 01.org: wget https://download.01.org/gfx/ubuntu/14.10/main/pool/main/i/intel-linux-graphics-installer/intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb – mchid May 6 '15 at 23:21
  • 2
    @NKN Then sudo gdebi intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb and finally, intel-linux-graphics-installer & – mchid May 6 '15 at 23:22
  • 2
    @NKN After you are done, you should probably reboot and then change /etc/lsb-release back to trusty and 14.04. – mchid May 6 '15 at 23:23
0

You can enable VDPAU and VAAPI using the VDPAU_DRIVERS=va_gl command. Here a link to the source http://www.webupd8.org/2013/09/adobe-flash-player-hardware.html

sudo apt-get install i965-va-driver

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install i965-va-driver libvdpau-va-gl1

Adobe flash does not allow acceleration by default so you have to create a config file like so:

sudo mkdir -p /etc/adobe
echo "EnableLinuxHWVideoDecode=1" | sudo tee /etc/adobe/mms.cfg
echo "OverrideGPUValidation=1" | sudo tee -a /etc/adobe/mms.cfg

This does not work well system wide as it conflicts with application that already take advantage of VDPAU. So, to run individual applications using VDPAU just follow this example.

VDPAU_DRIVER=va_gl firefox

This will run firefox and adobe flash with the VDPAU driver. I have also tested this with Gimp and a few others like VLC and mplayer.

Also, because /usr/bin/firefox is a simlink, you can safely erase this file like so:

sudo rm /usr/bin/firefox

and replace the file with the bash script to use VDPAU whenever you open firefox automatically like this (copy and paste entire command into an open terminal, both lines at once)

echo '#!/bin/bash
VDPAU_DRIVER=va_gl /usr/lib/firefox/firefox.sh' | sudo tee /usr/bin/firefox

And finally, to make it executable:

sudo chmod +x /usr/bin/firefox

Now you should have hardware acceleration and accelerated hardware decoding for firefox.

To get support for chrome or chromium, type:

chrome://flags

in the url bar and enable the option for "Override software rendering list" it's like the first on the list.

Then, use the "synaptic" package manager to search for opengl, or GL, with acceleration, rendering, decoding etc. Install all the gl support you can find, however, make sure to pay attention to the changes to be made to make sure you are not going to install something that will break your system by uninstalling needed applications by default in the process. (just pay attention and read before accepting any changes). If there is anything not supported on the chrome or chromium URL page

chrome://gpu

. . . you can usually install gl support to fix this. The only problem I haven't been able to fix is full accelerated decoding. This is not fully supported and usually throws an error during youtube videos and the like. Because chrome uses pepperflash instead of the regular adobe flash software, you will not be able to achieve acceleration by using the VDPAU_DRIVER=va_gl command with google chrome or chromium.

  • I will try this in the future. This could help me with make use of the graphics card, but I assume this soulution would be unlikely to help with Compiz and Xorg using CPUs unless it's applied system wide? – user307885 Jul 24 '14 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.