27

In upmenu I can only preserve view for folders.
I can press ctrl+4, but whats the way to change the default view permanent?
(Lubuntu 14.04, PCManFM 1.2.0)

4 Answers 4

36

Open PCManFM. Choose Edit->Preferences. Navigate to the bottom and set your View Mode.

8
  • I also use Lubuntu 14.04, PCManFM 1.2.0. In Edit ->Preferences, there is just no way to set the view mode!?
    – ubuplex
    Apr 7, 2015 at 11:29
  • Ubuplex: Look in the first tab (General). At the bottom you will see Default View. There is where you can change it.
    – Rex
    Apr 7, 2015 at 14:35
  • 1
    Who has given me a down badge for my true statement??? PCManFM will only record the view for the currently active folder, even if you select "record view" (or however it is named in the English version). It will just forget it for any other folder.
    – ubuplex
    Apr 9, 2015 at 8:37
  • 1
    I use Lubuntu 14.04, pcmanfm 1.2.0 and this works. Nov 20, 2016 at 16:14
  • 1
    solution still valid for Lubuntu 16.04, PCManFM 1.2.4
    – linolino
    Feb 21, 2018 at 13:06
4

I am using 0.13.0 and I needed to look quite awhile till I found the setting. This is a note to my future self when I forget this piece of info. Here is a picture to help visualize where the setting is. I did have to save it twice or so before it stuck. Maybe I should have restarted the computer or something first but setting it twice seems to work. Picture of Default View Mode for PCManFM in Preferences

1

I use Lubuntu 20.04. Open a Terminal (Ctr+Alt+t):

sudo nano /etc/xdg/xdg-Lubuntu/pcmanfm-qt/lxqt/settings.conf

now change the following part, so it looks like this:

[FolderView] Mode=List ...

It also fixed for me that the network-folder in pcman shows other computers in my network. Before it did not.

0

I use 18.04lts and PCmanFM (LXDE) , not the recent qt5 version. Using the above reply as a guideline I edited the file /etc/xdg/pcmanfm/lubuntu/pcmanfm.conf at the line reading "view_mode=0" inside the "[ui]" block.

For a detailed listing view use 3 (the choices 0,1,2,3 correspond to the dropdown list in pcmanfm itself) like so: "view mode=3"

Close and save. Worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.