1

Edit: I researched also link suggested above - it is option (3) And indeed is very helpful. Especially @LuisAlvarado's answer - it contains table which suggest using linux-firmware-nonfree - I tried and it did not worked (possibly because my system was polluted by remnants of previous attempts). Instead, b43-fwcutter from option (2) after clean reinstall worked for me. Linked answer contains good explanation of the process, but advice about exact module to use might be incorrect. wileress.kernel.org has different value value, which worked for me.

Original post:

I cannot get bcm4318 working on Lubuntu 14.4. This card worked on lubuntu 12.10 but upgrading failed, and after full reinstall from liveUSB I cannot get wifi to work. I tried these suggestions:

  • (1) Advice for 12.4 suggests to apt-get --reinstall install bcmwl-kernel-source
  • (2) This says: apt-get purge bcmwl-kernel-sourceinstead, says: apt-get install b43-fwcutter firmware-b43-installer but did not work either.
  • (3) This suggests apt-get install linux-firmware-nonfree - well worth reading, excellent explanation of problem.

Every time I purged packages from previous try and rebooted afterwards.

What else I should try?

I checked "ultimate authority" on bcm43xx wireless, http://wireless.kernel.org/en/users/Drivers/b43#Supported_devices which says (in debian section) to use option (2), but no luck.

By "no luck" I mean that iwconfig says no wireless connection.
In my office I have wired connection to modem but no apparent wireless.
Is iwconfig a right way to test if my wireless is alive?

lsmod | grep -e b43 -e wl:

b43                   356470  0   
bcma                   42043  1 b43  
mac80211              545990  1 b43  
cfg80211              409394  2 b43,mac80211  
ssb                    51854  2 b43,b44  

lspci -nn | grep 0280

06:02.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g]   802.11g Wireless LAN Controller [14e4:4318] (rev 02)  

uname -mr

3.13.0-24-generic i686  

My laptop is Acer Aspire 5610Z with 0.5GB of RAM which I am going to upgrade to 4GB ASAP.


I got it working.

Correct answer is option (2), at least for my combinations of whatever is relevant.

What probably caused my earlier problems was that I was installing using synaptic gui. When I did install using terminal and apt-get, I noticed that apt-get update complained about duplicate sources. Once resolved, I again went over whole installing exercise, including fresh reinstall (to make sure there are no remnants of other installs), and straight to option (2) as suggested by wireless.kernel.org.

Regarding other options, it is above my paygrade to decide if they are invalid and need to be updated, or can stay as is, if approaches suggested by (1) and (3) are correct and may work for someone else.

9
  • What driver is in place now? lsmod | grep -e b43 -e wl What is your exact card? lspci -nn | grep 0280 Please edit your question to add these details.
    – chili555
    Jul 21 '14 at 21:58
  • Try simply get into Settings -> software sources -> last tab -> select proprietary driver for that Broadcom.
    – enedil
    Jul 21 '14 at 22:12
  • I tried that first but I have no entries to select from. Do I need to enable some special repositories? Jul 21 '14 at 22:14
  • 1
    I believe you have the correct driver for your device. Is this your problem? askubuntu.com/questions/451593/…
    – chili555
    Jul 22 '14 at 0:39
  • Downvoter, care to explain why? Supposed duplicate does not answer my question, I tried it and mentioned in my research. I did what wireless.kernel.org said I should do, it worked, not sure why I my post was downvoted. Oh well, ife is too short to deal with such crap. Thank you for nothing. Jul 23 '14 at 2:11
3

Option number 2 worked for me. I had originally installed the bcmwl kernel source through the additional drivers gui. I later installed the b43w cutter and installer with no luck. After the bcmwl purge and b43w cutter reinstall it took off working. Thanks a bunch!

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install --reinstall b43-fwcutter firmware-b43-installer

Reboot. Enjoy Ubuntu!

0

I got it working.

Correct answer is option (2), at least for my combinations of whatever is relevant.

What probably caused my earlier problems was that I was installing using synaptic gui. When I did install using terminal and apt-get, I noticed that apt-get update complained about duplicate sources. Once resolved, I again went over whole installing exercise, including fresh reinstall (to make sure there are no remnants of other installs), and straight to option (2) as suggested by wireless.kernel.org.

Regarding other options, it is above my paygrade to decide if they are invalid and need to be updated, or can stay as is, if approaches suggested by (1) and (3) are correct and may work for someone else.

1
  • 1
    Hi Peter, please update the answer so it does not look like a comment but an actual answer, something like "I read the whole broadcom answer by Luis alvarado & Chili555 and it sucked, so I made a better one about the BCM4318 rev2 correct driver"... or something to that effect ^^. Jul 23 '14 at 17:25
-1

Ahhh! After a day of confusion and following simalar steps I went into software and updates and let it load (Note:this may take some time) and checked Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (propietary)

Also do note that Alt may take place of Fn in some cases

This may help: [http://www.broadcom.com/docs/linux_sta/README.txt ]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.