0

I have installed virtualbox on ubuntu 14.04 and installed windows xp as a guest. i have a usb stick and an external drive (western digital) that i want to mount in win xp. the mounting itself works, but windows xp displays: "USB device not recognized" and of course i cannot access it.

here is what I have already done:

  • (got windows xp updates)
  • installed guest additions
  • installed the extension pack
  • added user to virtualbox group
  • enabled usb controller + usb 2.0 (EHCI) controller
  • added filters for both, my usb stick and my wd extenal harddrive
  • set it to use only 1 cpu (settings -> system -> processor)
  • This sounds like Windows problem, but try restarting the VM. – Mitch Jul 21 '14 at 16:12
  • I've already done that many times. I've been working on it since yesterday.. – Doc Jul 21 '14 at 16:13
  • is the usb 3.0? I may be wrong, but windows xp is an old engine and maybe it doesn't understand usb 3... just a theory, doesn't know tho. – Geo Jul 21 '14 at 16:21
  • interesting thought. the external harddrive is indeed 3.0. but the usb stick is not – Doc Jul 21 '14 at 16:28
  • when i was searching other threads for this issue, most people apparently solved it by setting it to use only 1 cpu instead of 2 or 4 or whatever. i assumed i ought to do that in the virtualbox settings (system -> processor) and there it was already set to use only 1 (cannot use more than 1, even). but now i opened System Monitor and i saw that i am using 2 cpus. am i supposed to use only 1 there? – Doc Jul 22 '14 at 8:26
1

Had the same problem - I tried to uncheck the entire usb (1.1 and 2.0) before starting the guest.

Then XP recognized the usb

  • When XP booted and completed USB Driver install, you have to put the usb device through by selecting it in the "devices" tab in the machine menu which can be integrated when in the C View mode or center-down when Full view.
  • wow, this really did the trick. i went to settings -> USB, and unchecked both, enable usb controller and enable usb 2.0 controller. started the machine and it recognized the usb devices, because for some reason the filters i created for each still work (despite the unchecking of "enable the usb controller"). thanks! – Doc Jul 23 '14 at 14:07
0

(I can't seem to add a comment to the previous answer.)

I believe that turning off both EHCI and USB will actually automatically turn USB back on, but not EHCI. I noticed that if I simply turn off EHCI, then it works with MSWin XP. I haven't yet checked to see what kind of performance hit that may cause.

My guess is that the VirtualBox USB EHCI emulation changed and is no longer supported by the XP USB driver.

Edit: I'm running VirtualBox 4.3.10, but extensions 4.3.14. I downgraded the extensions to 4.3.10, and now EHCI works. I did not try version 4.3.12 of the extensions.

To find the old extensions in my web browser, I used the normal download link, but removed the last two path components, then followed 4.3.10 instead of 4.3.14. In other words, browse to http://download.virtualbox.org/virtualbox/4.3.10/ and download from there.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.