How to start hostsapd service every time my compute starts

I have Ubuntu Server 13.10 and kernel 3.11

When I tried sudo update-rc.d hostapd defaults I got the following

System start/stop links for /etc/init.d/hostapd already exist.

and sudo service hostapd status shows that the service is not running

  • 1
    possible duplicate of How can I configure a service to run at startup – Parto Jul 21 '14 at 8:18
  • @Parto Already tried that, doesn't work – loo3y35 Jul 21 '14 at 8:29
  • Is there anything useful in /var/log/syslog after "Starting advanced IEEE 802.11 management" if you try sudo service hostapd start manually? – Jos Jul 21 '14 at 9:21
  • sudo service hostapd start works perfectly, my only issue is starting the service automatically @Jos – loo3y35 Jul 21 '14 at 9:25
  • 1
    Does hostsapd need other services in up status to successfully complete its startup? – Lety Jul 21 '14 at 16:46

Sounds like you might have gotten past this, as the daemon reports it is running when querying status.

My /etc/default/hostapd file did not define where to find the hostapd.conf file (as provided by Ubuntu 14.04.1 LTS). And so, I received no output when running sudo service hostapd start or sudo service hostapd status.

Once I directed the out-of-the-box init script to a configuration file, the service was able to start, and show status.

Maybe this was done on purpose to force you to think about configuration before the wireless services start.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.