0

There are a number of questions that address holding back packages with apt or dpkg to prevent upgrades when doing a normal 'apt-get upgrade'. Will any of these methods work across a release upgrade? I'm finally upgrading from 12.04 to 14.04, and there are some packages (e.g., MySQL server) that I'd like to prevent from being upgraded.

0

Assuming such constraints were enforces by the upgrade manager, there's a good chance that you'll have broken dependencies and will have to hold back other packages to avoid the broken dependencies. If any of those other packages are critical/core packages, the upgrade manager will refuse to continue.

In the case of MySQL, this might be less likely based on the dependencies and reverse-dependencies of the mysql-server-5.5 package in Trusty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.