I am quite new to Ubuntu. (I started to use Ubuntu about a year ago, but I don't know how to use things like terminal well. All I used by console was easy things like ls or cd, to use gcc.)

Today, I found 'profile' property of the terminal, and I created a new profile. Then, I changed some properties like font color and opacity.

Soon, I found something like 'command', and for test, I set that to ls. I closed and re-opened the terminal. However, the terminal terminates right after it appeared. I soon remembered that there was option like 'close right after the command is executed'.

Therefore, I can't use Gnome Terminal D: ... I found Konsole at Ubuntu software center, but that's just not my style (especially cursor, its position is little weird...).

Question : How to change the profile of Gnome Terminal, without opening it?


Sounds like you've botched your profile up slightly by adding a custom command (something that runs as soon as it opens).

Thankfully you can edit your profile settings by running this (use Alt+F2):

gconf-editor /apps/gnome-terminal/profiles/Default

If you've botched up too much you can use the Etch-a-Sketch method and reset everything back to defaults:

gconftool --recursive-unset /apps/gnome-terminal/
  • Thanks! It works now! (PS. The site says that I can accept an answer in 2 minutes.)
    – JiminP
    Jun 22 '11 at 14:09

The command

gnome-terminal -e bash

will work around the profile command setting.

Once started, you can modify the profile.

  • This one works for me instead of the accepted answer.
    Nov 8 '16 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.