1

PROBLEM:

When in Zoneminder (version used:1.27.1) in the settings of your monitor, voice

Source tab as follows:

Remote Protocol: HTTP
Remote Method: Simple
Remote Host Name: root:miapassword@192.168.x.y
Remote Host Port: 8088
Remote Host Path: /cgi-bin/video.jpg
Target Colorspace: 24 bit color
Capture Width (pixels): 320
Capture Height (pixels): 240

enter image description here

but does not want to operate with a blue screen!

INFO AND NOTE:

  • I'm asking for help to install a Vivotek FD6122 IP Camera (manual at page 62 URL syntax: "http:///cgi-bin/video.jpg")

The camera works perfectly.
When I run its browser access: 192.168.xy: 8088/cgi-bin/video.jpg, it asks me:

user: root 
password: miapassword 

and I see the camera on quietly browser.

  • The VIVOTEK camera also works great from web administration panel (http://192.168.xy:8088/snapshot.vspx) and Android phone.

  • The behavior of browsers not working only in the VIVOTEK, only on Firefox by directly entering USERNAME and PASSWORD (method working on other IP cameras) root:miapassword@192.168.x.y:8088/cgi-bin/video.jpg

  • Zoneminder does not like USERNAME and PASSWORD to be empty. It is advisable to always use these two data otherwise, as happened in the other camera IP, does not display and shows the usual blue screen with timer and date working! As soon as I entered USERNAME and PASSWORD the other IP camera "magically" worked however, except for the "squeamish" Vivotek FD6122!

  • I did not find the model here Vivotek in Zoneminder. I tried the settings for the similar model (Vivotek FD8134) at the site of zoneminder

recommended settings Zoneminder (Vivotek FD8134):

Remote Protocol: RTSP 
Remote Method: RTP/RTSP 
Remote Host Name: Put in the cameras IP or hostname 
Remote Host Path: /live.sdp

and both Zoneminder, both from the browser, but without success in both cases.

  • log files of the three errors are repeated continuously:

    **Date/Time,    Component,   PID,   Level,   Message,   File,   Line**
    

    2014-07-22 17:46:10.632456 zmc_m3 3574 ERR Failed requesting writeable buffer for reading JPEG image. zm_image.cpp 993

    2014-07-22 17:46:10.597513 zmc_m3 3574 ERR Held buffer is undersized for requested buffer zm_image.cpp 314

    2014-07-22 17:46:10.222009 zmc_m3 3574 ERR Unable to decode jpeg zm_remote_camera_http.cpp 1120

1

Maybe much to late, but i also had that error for my wanscam clone camera

Failed requesting writeable buffer for reading JPEG image

I got it working perfectly; you just need to see that the resolution given in zoneminder is exactly the same as your camera's setting. I had my cams set as 640x480 and zoneminder as 320x240 and I got these errors and blue image on the cam.

So just kinda what was said above :)

| improve this answer | |
0

I know this is a few months old but just wanted to let you know that the Vivotek ip6122 (same as FD6122v but not a FAST DOME version) is working on my Zoneminder system. It took some messing about but here is what I did.

Incidental I'm running Zoneminder 1.27 on Ubuntu Server 12.04

The main issue is that you have to be accurate with the resolution settings in zoneminder otherwise you will not get a picture.

In the settings on the camera the resolutions are not clearly marked but are selectable once you know.

(If you are using a Linux system to browse the camera you can still make changes but you won't see any video on the screen because the web interface uses ActiveX; I have a virtual machine of Windows XP running so I can jump across if needed but you won't need this to get the camera running with Zoneminder.)

  1. If you navigate to the camera's ip address which will be something like 192.168.x.x then click on the 'configuration' button on the left.

  2. Enter the username and password if prompted (the default is: root & {blank password})

  3. Click on VIDEO on the left hand side.

  4. Change Size to any one of the following depending on the resolution you want zoneminder to run with:

    'Double' = 704x576
    'Normal x 2' = 352x288
    'Normal' = 352x288
    'Half' = 176x144
    'Half x 2' = 176x144

Notice that the "x 2" versions are the same resolution but seem to give better detail.

Double is the highest resolution you can go with this camera and works well, but might be slow and you will need to fix the bandwidth to around 384 or 512 kbps which you can adjust within the same screen you are currently on.

I'm going to assume our camera has been set to Normal for this tutorial. Click Save at the bottom and close your browser.

  1. Use the following data for setting up this camera in Zoneminder:

A: Set the Source Type to Remote on the General tab.
B: Use the following data within the Source Tab, use the appropriate resolution
settings in the Capture Width and Capture Height boxes that you set your camera to in Step 4, and use your own camera's IP address.

Remote Protocol = HTTP
Remote Method = Simple
Remote Host Name = 192.168.x.x
Remote Host Port = 80 (not 8088)
Remote Host Path = /cgi-bin/video.jpg
Target Colorspace = 24 Bit Colour
Capture Width (pixels) = 352
Capture Height (pixels) = 288
Preserve Aspect Ratio = {unchecked}
Orientation = Normal
Deinterlacing = Disabled

Then fill in any other details like name etcetera that you need to, and click save.

All done.

You should now see an image, if not check the usual IP address and resolution is correct, if you have a root password on your camera then depending on your installation you can either delete if from the camera within the settings page or insert root:{ your-password}@ in Zoneminder before the IP address in the 'Remote Host Name' box.

Trust that Helps!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.