13

I just installed UBUNTU 14.04 LTS on a Toshiba Satellite C655D. My wifi drops off occasionally, and all I have to do to reconnect is disable my wifi and enable wifi from the wireless icon in the top right. Its just annoying.

Any help would be appreciated, I am new to UBUNTU, but interested in learning the linux commands. Luckily some commands are similar to DOS and batch code.

I use a router and have no issues with other wireless devices at the moment, including another laptop running 14.04, but it is an older Aspire One.

Here is the info from the wireless_script that I found on the forum:

======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

Satellite-C655D 3.13.0-32-generic x86_64,  Ubuntu 14.04 LTS, trusty

CPU    : AMD C-50 Processor
Memory : 2606 MB
Uptime : 11:38:53 up  2:59,  2 users,  load average: 0.53, 0.67, 0.69

lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:8181]
Kernel driver in use: rtl8192ce
06:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8152 v1.1 Fast Ethernet [1969:2060] (rev c1)
Subsystem: Toshiba America Info Systems Device [1179:ff1e]
Kernel driver in use: atl1c

lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 003 Device 002: ID 10f1:1a34 Importek 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 046d:c06c Logitech, Inc. Optical Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~

iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     IEEE 802.11bgn  ESSID:"Home"  
      Mode:Managed  Frequency:2.457 GHz  Access Point: <MAC C-01 Home>   
      Bit Rate=18 Mb/s   Tx-Power=20 dBm   
      Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
      Power Management:off
      Link Quality=56/70  Signal level=-54 dBm  
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:90   Missed beacon:0

rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

  Interface        Soft blocked  Hard blocked
0: phy0: Wireless LAN      no            no

lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

rtl8192ce              53550  0 
rtl_pci                26690  1 rtl8192ce
rtlwifi                63475  2 rtl_pci,rtl8192ce
rtl8192c_common        53172  1 rtl8192ce
mac80211              630653  3 rtl_pci,rtlwifi,rtl8192ce
cfg80211              484040  2 mac80211,rtlwifi
wmi                    19177  1 toshiba_acpi

module parameters ~~~~~~~~~~~~~~~~~~

cfg80211      (2): cfg80211_disable_40mhz_24ghz=N | ieee80211_regdom=00
mac80211      (5): beacon_loss_count=7 | ieee80211_default_rc_algo=minstrel_ht | max_nullfunc_tries=2 | max_probe_tries=5 | probe_wait_ms=500
rtl8192ce     (5): debug=0 | fwlps=Y | ips=Y | swenc=N | swlps=N
wmi           (2): debug_dump_wdg=N | debug_event=N

nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

State: connected (global)
================o=============o===========o==============o=========o===========o==============o===========
 Interface & ID | Type        | Driver    | State        | Default | Speed     | Support      | HW Addr   
================o=============o===========o==============o=========o===========o==============o===========
 eth0           | Wired       | atl1c     | unavailable  | no      |           |              | <MAC eth0>
----------------+-------------+-----------+--------------+---------+-----------+--------------+-----------
 wlan0  [Home]  | 802.11 WiFi | rtl8192ce | connected    | yes     | 18 Mb/s   | WEP/WPA/WPA2 | <MAC wlan0>

MyCharterWiFia0-2G: Infra, <MAC C-NA MyCharterWiFia0-2G 1>, Freq 2417 MHz, Rate 54 Mb/s, Strength 40 WPA2
*Home:           Infra, <MAC C-01 Home>, Freq 2457 MHz, Rate 54 Mb/s, Strength 66
notyours:        Infra, <MAC C-02 notyours>, Freq 2452 MHz, Rate 54 Mb/s, Strength 20 WPA2

Address:         192.168.1.121
Prefix:          24 (255.255.255.0)
Gateway:         192.168.1.1
DNS:             removed
DNS:             removed
DNS:             removed
----------------+-------------+-----------+--------------+---------+-----------+--------------+-----------

NetworkManager.state ~~~~~~~~~~~~~~~

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

NetworkManager.conf ~~~~~~~~~~~~~~~~

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~

Home                 : ssid=Home | mac-address=<MAC wlan0> | ipv6=auto | ipv4=auto 

interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~

nameserver 127.0.1.1

Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

--- 192.168.1.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 2.315/2.845/3.376/0.533 ms

--- 127.0.1.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.088/0.088/0.088/0.000 ms

iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : "en_US.UTF-8")
country 00:
(2402 - 2472 @ 40), (3, 20)
(2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
(2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
(5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
(5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     13 channels in total; available frequencies :
      Channel 01 (2.412 GHz) - 13 (2.472 GHz)

      Current Frequency:2.457 GHz (Channel 10)

iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     Scan completed :
      Cell 01 - Address: <MAC C-01 Home>
                Channel:10
                Frequency:2.457 GHz (Channel 10)
                Quality=54/70  Signal level=-56 dBm  
                Encryption key:off
                ESSID:"Home"
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                          24 Mb/s; 36 Mb/s; 54 Mb/s
                Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                Mode:Master
                Extra:tsf=000000a88b1ceaa6
                Extra: Last beacon: 84ms ago
      Cell 02 - Address: <MAC C-02 notyours>
                Channel:9
                Frequency:2.452 GHz (Channel 9)
                Quality=24/70  Signal level=-86 dBm  
                Encryption key:on
                ESSID:"notyours"
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                          24 Mb/s; 36 Mb/s; 54 Mb/s
                Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                Mode:Master
                Extra:tsf=00000c380d063183
                Extra: Last beacon: 368ms ago
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : CCMP
                    Pairwise Ciphers (1) : CCMP
                    Authentication Suites (1) : PSK

blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[rtl8192ce]
filename:       /lib/modules/3.13.0-32-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware:       rtlwifi/rtl8192cfwU_B.bin
firmware:       rtlwifi/rtl8192cfwU.bin
firmware:       rtlwifi/rtl8192cfw.bin
srcversion:     EF063698748457BBEDB4633
depends:        rtlwifi,rtl_pci,rtl8192c-common,mac80211
parm:           swenc:Set to 1 for software crypto (default 0)
parm:           ips:Set to 0 to not use link power save (default 1)
parm:           swlps:Set to 1 to use SW control power save (default 0)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
parm:           debug:Set debug level (0-5) (default 0) (int)

[rtl_pci]
filename:       /lib/modules/3.13.0-32-generic/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
srcversion:     D5E4890DC428FA5A1BF92DF
depends:        mac80211,rtlwifi

[rtlwifi]
filename:       /lib/modules/3.13.0-32-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
srcversion:     E1F4663325225EE8DBA54CA
depends:        mac80211,cfg80211

[rtl8192c_common]
filename:       /lib/modules/3.13.0-32-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192c/rtl8192c-common.ko
srcversion:     32F826C623BC49F764F7974
depends:        

[mac80211]
filename:       /lib/modules/3.13.0-32-generic/kernel/net/mac80211/mac80211.ko
srcversion:     8ADA881D348148A3358334C
depends:        cfg80211
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/3.13.0-32-generic/kernel/net/wireless/cfg80211.ko
srcversion:     E786D076B61F97809B04B64
depends:        
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~

# PCI device 0x1969:0x2060 (atl1c)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0x8176 (rtl8192ce)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules        : Default
/etc/rc.local       : Default
/etc/modprobe.d     : Not Default
/etc/pm/(cnf|pw|sl) : Default

[/etc/modprobe.d]
mlx4.conf         : softdep mlx4_core post: mlx4_en

Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/vmlinuz-3.13.0-32-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7

dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[    2.226619] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[    2.227831] audit: initializing netlink socket (disabled)
[    4.141892] psmouse serio1: elantech: assuming hardware version 3 (with firmware version 0x250f01)
[   13.317618] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.029316] wmi: Mapper loaded
[   16.024516] rtl8192ce: Using firmware rtlwifi/rtl8192cfw.bin
[   16.245437] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   16.246292] rtlwifi: wireless switch is on
[   21.829897] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   21.831623] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   24.389024] wlan0: authenticate with <MAC C-01 Home>
[   24.410340] wlan0: send auth to <MAC C-01 Home> (try 1/3)
[   24.413577] wlan0: authenticated
[   24.421609] wlan0: associate with <MAC C-01 Home> (try 1/3)
[   24.423984] wlan0: RX AssocResp from <MAC C-01 Home> (capab=0x401 status=0 aid=8)
[   24.424197] wlan0: associated
[   24.424263] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   24.428436] wlan0: deauthenticating from <MAC C-01 Home> by local choice (reason=2)
[   24.429155] wlan0: authenticate with <MAC C-01 Home>
[   24.429441] wlan0: send auth to <MAC C-01 Home> (try 1/3)
[   24.431321] wlan0: authenticated
[   24.437667] wlan0: associate with <MAC C-01 Home> (try 1/3)
[   24.440062] wlan0: RX AssocResp from <MAC C-01 Home> (capab=0x401 status=0 aid=8)
[   24.440264] wlan0: associated
[   34.446201] wlan0: deauthenticating from <MAC C-01 Home> by local choice (reason=3)
[   35.753724] wlan0: authenticate with <MAC C-01 Home>
[   35.770004] wlan0: send auth to <MAC C-01 Home> (try 1/3)
[   35.771843] wlan0: authenticated
[   35.774700] wlan0: associate with <MAC C-01 Home> (try 1/3)
[   35.777297] wlan0: RX AssocResp from <MAC C-01 Home> (capab=0x401 status=0 aid=8)
[   35.777513] wlan0: associated
[  643.559339] wlan0: deauthenticated from <MAC C-01 Home> (Reason: 7)
[  643.598481] wlan0: authenticate with <MAC C-01 Home>
[  643.598787] wlan0: send auth to <MAC C-01 Home> (try 1/3)
[  643.604888] wlan0: authenticated
[  643.606162] wlan0: associate with <MAC C-01 Home> (try 1/3)
[  643.610387] wlan0: RX AssocResp from <MAC C-01 Home> (capab=0x401 status=0 aid=8)
[  643.610641] wlan0: associated
[  713.319037] wlan0: deauthenticated from <MAC C-01 Home> (Reason: 7)
[  728.408563] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  738.592725] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  739.601499] wlan0: authenticate with <MAC C-01 Home>
[  739.935776] wlan0: send auth to <MAC C-01 Home> (try 1/3)
[  740.038620] wlan0: send auth to <MAC C-01 Home> (try 2/3)
[  740.142648] wlan0: send auth to <MAC C-01 Home> (try 3/3)
[  740.246553] wlan0: authentication with <MAC C-01 Home> timed out
[  741.192350] wlan0: authenticate with <MAC C-01 Home>
[  741.201644] wlan0: send auth to <MAC C-01 Home> (try 1/3)
[  741.203327] wlan0: authenticated
[  741.207022] wlan0: associate with <MAC C-01 Home> (try 1/3)
[  741.210702] wlan0: RX AssocResp from <MAC C-01 Home> (capab=0x401 status=0 aid=8)
[  741.211034] wlan0: associated
[  741.211120] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1438.357303] wlan0: deauthenticating from <MAC C-01 Home> by local choice (reason=3)
[ 1442.614329] rtlwifi: wireless switch is on
[ 1446.371442] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1447.389541] wlan0: authenticate with <MAC C-01 Home>
[ 1447.389841] wlan0: send auth to <MAC C-01 Home> (try 1/3)
[ 1447.396790] wlan0: authenticated
[ 1447.400822] wlan0: associate with <MAC C-01 Home> (try 1/3)
[ 1447.403732] wlan0: RX AssocResp from <MAC C-01 Home> (capab=0x401 status=0 aid=7)
[ 1447.403921] wlan0: associated
[ 1447.404002] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

======== Done ========
  • Why is Wireless 'n' an issue?? – user2160518 Aug 16 '14 at 7:27
14

First in your router change 802.11bgn to 802.11bg.

Second change the wep encryption to just wpa2 (CCMP)(AES) not (TKIP) if you have that option it will work best.

Third set your wireless channel in the router to 1 or 11 then save the router configuration and reboot it.

Fourth go into network manager at top right corner of the screen and click on edit connections>wireless tab and set IPV6 to ignore.

Now open the terminal CTRL+ALT+_T then copy and paste the following code one line at a time for accuracy:

echo "options rtl8192ce swenc=1 ips=0" | sudo tee /etc/modprobe.d/rtl8192ce.conf
sudo modprobe -rfv rtl8192ce
sudo modprobe -v rtl8192ce
  • Thanks, I just did this on my laptop running Ubuntu 15.04, and seems like it is working. – user8951 Apr 20 '15 at 0:21
  • This's great! Have been struggling for a week, now it's working on Ubuntu 14.04. Thank you very much. – Ehsan M. Kermani Jun 16 '15 at 19:37
1

I had the same problem - I was lazy so I did only No. 4

"go into network manager at top right corner of the screen and click on edit connections>wireless tab and set IPV6 to ignore"

...and it worked! Thanks

  • I agree, I've been using this card for years using wireless n only on multiple laptops and disabling ipv6 is all that is needed, except maybe set retry to a larger number in iwconfig for extra distance. – mchid Nov 28 '15 at 21:41

protected by Community Jan 27 '17 at 11:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.