3

This question already has an answer here:

I have here 5GB zip file but I have no idea how to unzip that.

I tried:

7z x file.zip 

Returns: Error: Can not open file as archive

jar xvf file.zip 

Returns: jar: error opening file.zip for reading: Value too large for defined data type

unzip file.zip 

Returns:

End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
note:  file.zip may be a plain executable, not an archive
unzip:  cannot find zipfile directory in one of file.zip or
        file.zip.zip, and cannot find file.zip.ZIP, period.

The file does seem to be a zip archive:

$ file file.zip
file.zip: Zip archive data, at least v1.0 to extract

Any idea?

Thanks.

marked as duplicate by LnxSlck, Eric Carvalho, Panther, karel, Radu Rădeanu Jul 22 '14 at 6:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The correct way to unzip a zip file is : unzip file.zip it looks like your zip file may be corrupted. Can you download it again and do a checksum to see if the file is ok? – LnxSlck Jul 20 '14 at 12:13
  • 2
    "note: file.zip may be a plain executable, not an archive" - what does file file.zip say? – steeldriver Jul 20 '14 at 12:15
  • @LnxSlck: how to do a checksum? I'm Ubuntu newbie, can you please help me? The other things I tried when unzip file.zip didn't work. – panther Jul 20 '14 at 12:18
  • @steeldriver: file.zip: Zip archive data, at least v1.0 to extract – panther Jul 20 '14 at 12:19
  • 1
    do you know who made it? Because... I would assume there might be a 2nd file (and more) to make up the complete file. – Rinzwind Jul 20 '14 at 15:19
2

The file does indeed appear to be a zip archive. I have no idea why you're getting this problem. It sounds like a limitation of unzip but that, again, is very unlikely. Anyway, one possible workaround is to use zcat instead. However, this will only work as expected if the compressed data is a single file, not a bunch of files and directories:

zcat file.zip > file.unzipped

The other option of course is that the file is either corrupt (you say it's not in your comment but give no evidence to support the claim) or part of a larger archive. Without more information about the file itself we can't help.

  • it returns gzip: file.zip has more than one entry--rest ignored - in the archive, there are more files, not just one (if I understood well error message). – panther Jul 20 '14 at 13:35
  • @panther yes, that makes sense. It was a long shot. Are you sure this is not just a single piece of a larger archive? Where did you get the file from? What makes you so sure it's not corrupt? – terdon Jul 20 '14 at 13:38
  • yes, I'm sure it's complete and not corrupt archive, because on Windows on the other computers in the past we opened similar files regularly (it's a partional backup of e-mail data). This zip file was created with the same bash script on server. – panther Jul 20 '14 at 14:32
  • @panther that does not mean its not corrupted. Can you open this particular archive on Windows? A file can be corrupted when you transfer it between computers for example. Or when something changed while the archive was being created. – terdon Jul 20 '14 at 14:33
  • No, I have no chance to try to open this file on another computer :-( – panther Jul 20 '14 at 14:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.