7

i can't find how to install and use the labelwriter 450 and it's urgent. i print for my job 50 to 100 labels per week.

i don't know what to do, i just went to ubuntu from windows 8.1.1.

I tried with wine but still doesn't work.

5 Answers 5

10

To install Dymo 450 LabelWriter on Debian Systems - Ubuntu, Raspibian, you might need first: (helped me to compile drivers, advice from : http://ubuntuforums.org/showthread.php?t=1502581 )

sudo apt-get install libcups2-dev libcupsimage2-dev gcc g++

Then you want to do install dymo linux sdk (both links work at 2016-05-14):

Then you unpack it, compile and install driver:

./configure
make
sudo make install

Later I've added driver via cups web interface like any other driver, choosing right ppd file. (example project : https://www.hmazter.com/2013/05/raspberry-pi-printer-server-for-labelwriter and another: https://gist.github.com/gwpl/6d6c1457b4d1f6b778917a2f7c3c57fd ).

Finally, I share via network Dymo 450 LabelWriter(s) attached to Ubuntu and Raspibian with other Linuxes (including Archlinux) and I've found that to make printing via network (e.g. ipp:// and ipps:// ) to work, I need to schedule printing (of pdf, png, whatever) add -o raw to lpr command. You will see example of -o raw in https://gist.github.com/gwpl/6d6c1457b4d1f6b778917a2f7c3c57fd and https://askubuntu.com/a/748035/31300 .

Finally references for installing and using Dymo 450 under Linux:

3
  • Sadz, the links have stopped working in 2018 Apr 19, 2018 at 18:07
  • Which links? As I checked they seem working. I've just downloaded dymo cups drivers package, I see tutorials. Apr 21, 2018 at 10:08
  • var.dymo.com/US/resources/sdk/linux is no longer pointing to the SDK/CUPS but the first one is (at this point ;-) )
    – Ray Oei
    Dec 6, 2018 at 12:25
9

14.04 and later

Open the terminal and type:

sudo apt install printer-driver-dymo
7

You need to get the correct drivers for CUPS, the Linux printing system. As far as I can tell, you can download them here:

https://dymo.custhelp.com/app/answers/detail/a_id/101/~/dymo-drivers-and-downloads#lw_linux

2
  • you may also find the discussion here useful: ubuntuforums.org/showthread.php?t=861781 Jul 20, 2014 at 12:02
  • CUPS driver installation could not be enough: "The printer setup requires an appropriate PostScript Printer Definition (PPD) file. Unfortunately, this seems not to be part of the installation package. For this reason, we need to download the CUPS driver provided by Dymo. This is currently version 1.4.0, which can be downloaded here. Afterwards the archive needs to be extracted. The model file is part of it and should be copied to the default model folder of CUPS." quote from baitando.com/it/2017/12/12/… where there are all the needed steps Jul 18, 2020 at 10:48
4

The answer by Grzegorz kinda works, but there is an issue in the official DYMO sources which prevents it from building on the latest version of CUPS. I found a patch on this Ubuntu forum post which contains the fix for it.

The post's instructions were:

git clone https://aur.archlinux.org/dymo-cups-drivers.git

Then copy that files inside the folder of driver, and finally:
* patch -Np1 -i cups-ppd-header.patch
* ./configure
* make
* sudo make install 

Basically, several files are missing this line, which makes it impossible to build:

#include <cups/ppd.h>

I made the change against the official version 1.4.0.5 copy of the source and put it in a repository for others to use: https://github.com/Kyle-Falconer/DYMO-SDK-for-Linux

3
  • Wait, but that link is from arch linux. This is an Ubuntu forum; how does that work? Apr 17, 2019 at 13:58
  • 1
    @LimitedAtonement It works just fine because in the end you have to compile the program with make, I've been using it on Ubuntu and Raspbian. The easiest way to get the drivers working are to use the copy on my github. Let me know if you run into issues. Apr 17, 2019 at 16:54
  • 1
    Forwarded from MousyBusiness: Kyle Falconers github repo is the solution for me. It seems there are several missing files which he has corrected
    – zx485
    Apr 23, 2019 at 21:34
1

Just FYI: If you need a label printer, do not buy a DYMO from this point in time onwards.

I have contacted their customer support and although not properly mentioned on their website, they have stopped supporting Linux as of this point in time.

3
  • They have a "if it works, it works, but if it fails, we won't fix it", policy with respect to the Labelwriter 450. That's what fuels the printer-driver-dymo package. For the other Dymo (the part I can see doesn't have a model nr), we have contacted them and got he "you're on your own" reply....
    – rew
    Sep 3, 2020 at 14:18
  • Any alternatives? May 2, 2021 at 13:18
  • No, I don't know. I bought a ZJ9200 that advertized: "with Linux support". That statement was a mistake. They pointed me to android drivers and stuff like that. (Android is linux, right? ... In a way, yes, but not really....) I've made a driver for that myself. It is in a "works for me" state. Not yet a CUPS driver where it is integrated into the printing system.
    – rew
    May 3, 2021 at 14:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.