I completely messed up my things, I was using ubuntu 14.10, yesterday I was updating it and during the installation my laptop got switched of as it ran out of battery and then I do not know what exactly happened, now when I switch it on all I get is a black screen with cursor blinking there, I am not that good with softwares as I am a medical student and have many important file there which I definitely do not want to loose so please let me know if this can be fixed or not I do not want to loose my things there... And by reading many post I tried doing some things on my own so I used:

Ctrl+Alt+F1 

and then on my black screen I this little explanation about ubuntu there help site and then this error:

E: Error: BrokenCount > Orun-parts: /etc/update-motd.d/90-updates-available exited with return code 255

Please help:(

closed as off-topic by karel, chaskes, user68186, Braiam, Eric Carvalho Jul 21 '14 at 11:18

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – karel, chaskes, user68186, Braiam, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What is your graphics card? can you connect to internet without screen in Ctrl+ Alt +F2 ? – user308564 Jul 20 '14 at 4:57
  • Hey thanks for you comment and time, well no I can not and I did how one of the user directed me to do in his answer below and after that please read my latest comment below for my current situation. – user307318 Jul 20 '14 at 7:02
up vote 12 down vote accepted

Such a situation can come if the installation is stopped midway. Good news is that all your files are safe there. Also, during update all the required files were already downloaded to your laptop (otherwise installation would not have started.)

So, now you just need to complete the installation process. First, Ctrl+Alt+F1 (or F2, f3, f4 anyone is fine.) Then you would reach the linux console. Login with your username and password there. Then issue the following command:
sudo dpkg --configure -a

This should complete your update and your system should be back up after a reboot. If the above gives errors of broken packages, issue the below command:
sudo apt-get install -f

And then run the above command again.

P.S: Did you really mean Ubuntu 14.10 ? That's an alpha-release software, NOT meant to be used for daily use. You must switch to 14.04 as soon as possible.

  • Hey Ashish, thanks for the support and I will surely do that once my system is up, so I ran, those commands that you wrote and after everything it says, errors were encountered while processing: Cgmanager Systemd-shim Libpam-system:amd64 Indicator-datetime Unity-contrôlée-centre Udisks2 Gvfs-daemons Pulseacaudio Gvfs-backends Indicator-sound Libcanvrra-pulse:amd64 Gvfs:amd64 Python3-checkbox-ng Python3-checkbox-support Checkbox-ng Gvfs-fuse Deja-dup-backend-gvfs Checkbox-ng-service Brasero Nautilus Nautilus-sendto Gnome-sudoku. Please help. – user307318 Jul 20 '14 at 6:44
  • Hey new update, now it says: dpkg: error processing package gnome-sudoku (configure): package is in very bad inconsistent state: you should reinstall it before attempting configuration. Then it says errors were encountered while processing: gnome-sudoku – user307318 Jul 20 '14 at 6:56
  • Just wondering how did this happen after the 1st one? Anyways, gnome-sudoku is just a game. You could as well sudo apt-get remove gnome-sudoku and sudo apt-get install -f Then reboot and check if you get a login prompt. – Ashish Jul 20 '14 at 7:11
  • 1
    Hey it's not getting removed it says: dpkg: error processing package gnome sudoku (--remove): package is in a very bad inconsistent state; you should reinstall it before attempting a removal Errors were encountered while processing: gnome-sudoku E: sub-process /user/bin/dpkg returned an error code (1). – user307318 Jul 20 '14 at 8:17
  • Then remove the broken package via the following command: sudo dpkg --remove --force-remove-reinstreq gnome-sudoku Then reboot and update. – Ashish Jul 20 '14 at 12:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.