1

My laptop worked fine earlier today, but just now I started it up and logged in, but my desktop is empty, my panels/toolbars/status bars are gone, and while I can move the mouse, right-clicking does nothing. I've rebooted several times (selecting both Xubuntu and XFCE sessions at login) and the problem persists. Xmonad sessions seem to start normally, though (I only vaguely know how Xmonad is supposed to work, though, so I only tested basic features ).

  • does xfwm4 help? – noleti Jul 20 '14 at 4:33
  • Nope, just raises "Gtk-WARNING **: cannot open display". Also, this time that I switched to tty, some output got shoved next to the login prompt: "*Starting crash submission daemon. [ OK ]". – Jonathan P Jul 20 '14 at 4:38
  • have you tried to logging in using a guest account? – mchid Jul 20 '14 at 4:51
  • Yeah, same problem. – Jonathan P Jul 20 '14 at 5:00
2

I just had this same problem and solved it by removing my ~/.cache and ~/.config/xfce4-session folders. After that I just ran 'service lightdm restart' so it would repop the session choices and my normal Xfce desktop was there.

  • I don't have any session folder in .config or in .config/xfce4... Any ideas? Removing cache folder alone didn't help... – WarrenFaith Jul 21 '14 at 9:11
  • No clue. My problem seemed to be that 'xfce4-session' wasn't firing up after authenticating to lightdm. I booted into Joe's Window Manager (jwm) and ran xfce4-session from there and the normal Xubuntu panels and stuff populated and overlaid the jwm environment. After that is when I removed those folders. You might try booting into another windows manager and running xfce4-session from a terminal emulator to see that it actually still works. – David Pierce Jul 21 '14 at 16:02
  • I was able to pin point it down to some crash reports from i915 package which is from Intel for the graphics driver. I removed the package and finally after a reboot it worked. I had some crash reports earlier but never an empty desktop... – WarrenFaith Jul 21 '14 at 16:04
0

Try this command, it worked for me:

xfdesktop --replace

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.