1

this is my first time posting on AskUbuntu so forgive me if I make any mistakes in my post. About an hour ago I installed Ubuntu 14.04 64-bit, I went to the Ubuntu Software Center to install my preferred browser on the OS Chromium.

Being a freshly installed OS I would have to download the repository information for the "universe" source. I went onto the "more info" section of the Chromium Web Browser page of the Software Center and clicked Use "This Source". It gave me the following error message.

Failed to download repository information
Check your internet connection.
Details
E:GPG error: http:// dl  stable  InRelease: Clearsigned file isn't valid, got     'NODATA' (does the network require authentication?)

I know for a fact I have a strong internet connection, any idea how to fix this?

2
  • Do you get the same error when running sudo apt-get update? Also, are you using a proxy? Jul 20, 2014 at 2:38
  • Yes, I do get the same error. Jul 20, 2014 at 2:39

3 Answers 3

0

Run:

gksudo gedit /etc/apt/sources.list

In the resulting Gedit file, find the line with http:// dl stable InRelease

Replace the line with:

deb http://dl.google.com stable InRelease
deb-src http://dl.google.com stable InRelease

then save and close the file.

Then run an Update:

sudo apt-get update
0

Go to the software center and click on edit from the menu.

From the dropdown menu click "software sources".

From here you will be able to select Universe.

You will need to submit a password to make changes and may even have to select Universe if the box does not remain checked.

It should update automatically, if not use the command

sudo apt-get update
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get upgrade

please post any errors.


You can also do this by editing the /etc/apt/sources.list file and deleting the " # " mark at the beginning of each line that ends with the word " universe " such as, these four lines here:

# deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
# deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe

need to be changed to

deb http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty universe
deb http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ trusty-updates universe

and these two need to be uncommented as well for security updates

# deb http://security.ubuntu.com/ubuntu trusty-security universe
# deb-src http://security.ubuntu.com/ubuntu trusty-security universe

by changing them to this

deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe

Click save and then run

sudo apt-get update
sudo apt-get upgrade && sudo apt-get install chromium-browser
0

you may also get the same error while using sudo apt-get update command! it was my problem too! go to software center -> Edit -> Software Sources -> Other Software. Now uncheck

http://dl.google.com/linux/chrome/deb now close Software Center and use the command again! i hope you have solved the problem by now ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.