0

Fresh Ubuntu 14.04 install.

I can play sound just fine, but there's no sound indicator. If I go to system settings and then into sound I can make it pop up - but it's in a mute position and I can't change the volume...

The sound devices in the sound settings don't show up and the volume control doesn't work...

However I can set the volume fine on the login screen!

1

Part-1:

See if the following steps help:

sudo dpkg-reconfigure $(dpkg -l | grep indicator-sound | awk '{print $2}' | tr '\n' ' ')
sudo update-initramfs -u

Reboot the system.

Still no sound indicator? Then try reinstalling it:

sudo apt-get -f install --reinstall indicator-sound indicator-sound-gtk2

Reboot the system.

Original answer here: https://askubuntu.com/a/363369/298860


Part-2: (Update)

sudo apt-get remove --purge alsa-base
sudo apt-get remove --purge pulseaudio
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo reboot

Then ...

sudo apt-get install alsa-base
sudo apt-get install pulseaudio
sudo alsa force-reload
sudo reboot

If one reboot doesn't do the trick, reboot a couple of times! (No, seriously!)

  • Hi, thank you I managed to fix the sound indicator. However the problem remains of the input section in the sound settings being empty. On top of that now I have no sound. If I kilall pulseaudio it comes back, and the input section fills, however the digital output is selected instead of my sound card, and I have to change that for sound to come back :(. – Jasiek Vetulani Jul 20 '14 at 10:01
  • see if "part-2" in my updated answer solves your problem. – thatmaheshrs Jul 20 '14 at 16:33
  • Doesn't work. Furthermore uninstalling pulse-audio causes these packages to get uninstalled in the process: indicator-sound* indicator-sound-gtk2* libcanberra-pulse* pulseaudio* pulseaudio-module-bluetooth* pulseaudio-module-x11* unity-control-center* unity-control-center-signon* webaccounts-extension-common* xul-ext-webaccounts* And the indicator disappears completely after that. Need to reinstall ubuntu-base to get it back and all those other packages. Still need to kill pulseaudio after login, before I get the card to show in sound settings and have sound. – Jasiek Vetulani Jul 26 '14 at 19:02
  • sudo alsa force-reload Indeed fixes it, but just as killing pulseaudio, and without reboot. However it only lasts till I logout, and I have to do it on every login. – Jasiek Vetulani Jul 26 '14 at 19:27
1

Open your terminal either via dash or ctrl+alt+t and paste in the following:

sudo apt-get install indicator-sound-gtk2

Then restart you pc and check your indicators again.

1

I had the same problem. When starting my machine I could hear the Ubuntu startup sound. But when logged in there was no sound device to select (and no sound). Apparently I'd thrown out a bit too many dependencies when trying to remove the pulseaudio equalizer.

The line that saved my life was:

sudo apt-get install alsa-base* indicator-sound* libcanberra-pulse* osspd* osspd-pulseaudio* pulseaudio* pulseaudio-module-bluetooth* pulseaudio-module-x11* unity-control-center* unity-control-center-signon* webaccounts-extension-common* xul-ext-webaccounts*
1

There was a dummy user for speech-dispatcher that was trying to run the pulseaudio daemon, so I had two pulseaudio-daemons trying to run at the same time, running this made it so that the audio devices are visible on boot:

sudo update-rc.d -f speech-dispatcher remove

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.