2

I am a total newbie to Ubuntu, and I'm not sure what to do here. I have a Toshiba Chromebook. I had a friend install the latest version of Ubuntu on it for me. For a while, the audio in Ubuntu was working fine, but now I can't hear any audio whatsoever.

How can I fix this?

3 Answers 3

2

Hope this helps other Linux users on their Chromebooks with the BayTrail hardware.

I bought a new FHD Toshiba Chromebook, installed Mint 17.3 Xfce4 on it straight away (modified the BIOS & conductive sticker).

Everything rocked except for the sound.... my symptom was that I only had the HDMI outputs, no speakers, no analog.

To fix this I did the following:

  1. Update the kernel version from 3. something to 4.2.0-23 by using the update manager. (start the gui version of the update manager, click View > Linux Kernels, click at least the 4.2.0-23 version)

  2. Update / install the linux-firmware package:

    sudo apt-get install linux-firmware
    
  3. Download this Intel blob (click the link to download)

    https://kernel.googlesource.com/pub/scm/linux/kernel/git/firmware/linux-firmware/+/refs/heads/master/intel/fw_sst_0f28.bin-48kHz_i2s_master

    Store it here:

    /lib/firmware/intel 
    
  4. Download the modified sound config file (asound.state) from https://gist.github.com/n1trux/3751a87f374a8af5f611 Open a terminal window and type

    sudo alsa force-unload 
    

    This temporarily kills the audio services.

    Replace the system’s sound config file with the downloaded version:

    sudo cp ~/Downloads/asound.state /var/lib/alsa
    
  5. Reboot, open pavucontrol and unmute your analog speakers, also perhaps check alsamixer: speaker should be enabled or allowed to be enabled.

1

I had the similar problem recently after updating my Toshiba chromebook which runs Ubuntu 14.10 using crouton. The sound stopped working (although it did detect an output device "cras"). An update to crouton (instructions here) solved the issue for me.

0

Check sounds in the system settings to ensure that your computer is not trying to play through an HDMI device. The computer I am using has only a single audio capable device, but my other computer has both, and the HDMI output is silent (unless plugged into something).

enter image description here

6
  • That white box is completely empty for me... What does that mean?
    – user307147
    Jul 19, 2014 at 15:20
  • That would indicate that ubuntu does not see any sound devices in your computer. You might try adding support for the non-free firmware (the firmware with no sourcecode available) sudo apt-get install linux-firmware-nonfree Jul 19, 2014 at 15:24
  • I tried that, still no sound devices. :(
    – user307147
    Jul 19, 2014 at 15:48
  • You could try the suggestions in this link askubuntu.com/questions/470876/… Jul 19, 2014 at 15:56
  • I followed the link that person posted. When I entered the command into the terminal, it said : /usr/local/chroots/raring does not exist; cannot update. did i download it wrong?
    – user307147
    Jul 19, 2014 at 16:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .