2

So I just got ubuntu and even when running the live disk I had an issue where I couldn't click most of the time and the mouse would jump left every 3 seconds I thought once I got installed and updated it would be fine. Now I can click fine but it still jumps and the touchpad doesn't work at all.

I have an ASUS laptop with touchscreen (which works perfectly) and a logitech g300 mouse.

After some searching I figured out how to do basic stuff with xinput and when I did an xinput list command i got this:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Gaming Mouse G300                id=10   [slave  pointer  (2)]
⎜   ↳ USBest Technology SiS HID Touch Controller    id=13   [slave  pointer  (2)]
⎜   ↳ PS/2 Logitech Wheel Mouse                 id=16   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Logitech Gaming Mouse G300                id=11   [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=12   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=14   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=15   [slave  keyboard (3)]

Instantly noticed that I don't have a ps/2 mouse so no idea why but it doesn't detect my touchpad and has added a duplicate generic device for my usb mouse. If I disable id 16 then everything is golden until i restart and have to repeat the command. How can I fix this up so I can get my touchpad working and the duplicate mouse removed permanently?

Thank you

EDIT 1:

After further attempts I have found that

sudo modprobe -r psmouse

sudo modprobe psmouse proto=imps

Also stops the cursor jumping and removes the generic mouse device (id=16) But I just found if i then touch the touchpad things get hectic and keyboard stops working properly and mouse clicking doesn't work.

Are there no drivers for the touchpad asus uses or something?

  • put the command into /etc/rc.local – noleti Jul 19 '14 at 13:58
  • that prevents the cursor jump but doesn't get the touchpad working – Jason Wright Jul 20 '14 at 7:49
  • added the line but it doesn't run on startup - still have to enter manually – Jason Wright Jul 21 '14 at 2:22
  • Can you add information on which command that is? – noleti Jul 21 '14 at 2:46
  • xinput set-prop 16 "Device Enabled" 0 that makes my usb mouse usable again but doesn't fix the issue of no touchpad – Jason Wright Jul 21 '14 at 7:42
2

Found a solution that works perfectly as long as you don't use gestures or scrolling etc Adding the line "psmouse.proto=bare" to the kernel cmd line on boot will, as I understand, emulate the basic moving and clicking tap to click etc using generic ps2 mouse drivers for the touchpad. There appears to be no drivers or support for the touchpads use in many asus laptops so as far as I can tell this is the best solution until drivers are added.

Permanently Add a Kernel Boot Parameter Log in to the system and start a terminal window (Applications->Accessories->Terminal).

  1. In the terminal window at the $ prompt, enter the command: sudo gedit /etc/default/grub

  2. Enter your password when prompted by [sudo]. At the line beginning with "GRUB_CMDLINE_LINUX_DEFAULT" add psmouse.proto=bare to the text inside the double-quotes after the words "quiet splash". (Be sure to add a SPACE after "splash" before adding your new parameter.) Click the Save button, then close the editor window.

  3. In the terminal window at the $ prompt, enter the command: sudo update-grub

  4. Restart the system.

0

Reinstall the driver package:

sudo apt-get --purge autoremove xserver-xorg-input-synaptics && sudo apt-get install xserver-xorg-input-synaptics

Then reboot.

  • tried this and no change - touchpad still doesn't show up in xinput list TT – Jason Wright Jul 20 '14 at 7:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.