10

Running Ubuntu 14.04 on my Intel NUC and using it right now as a HTPC, running XBMC.

When I insert a USB drive, Ubuntu recognizes it and shows the drive in Nautilus, in the panel on the left.

But the USB drive is not automatically mounted, I have to specifically click on the USB device in Nautilus and then it mounts and shows me the contents.

But when I'm using it as my HTPC with XBMC, this gets annoying because then I need to close out of XBMC, mount the drive by clicking on it and restart XBMC.

Any setting that I need to alter so USB drives are not only recognized, but also mounted automatically?

  • what does this return, should be true. gsettings get org.gnome.desktop.media-handling automount – doug Jul 19 '14 at 13:24
  • This does return true ;). – Timo Verbrugghe Jul 21 '14 at 13:20
15

sudo apt-get install usbmount

automatically mount and unmount USB mass storage devices This package automatically mounts USB mass storage devices (typically USB pens) when they are plugged in, and unmounts them when they are removed. The mountpoints (/media/usb[0-7] by default), filesystem types to consider, and mount options are configurable. When multiple devices are plugged in, the first available mountpoint is automatically selected. If the device provides a model name, a symbolic link /var/run/usbmount/MODELNAME pointing to the mountpoint is automatically created.

  • Mmm... now the USB does mount automatically, but XBMC does not show any message that a USB drive is inserted (when it should normally display a message like "Show files on this USB drive", etc...). But this does answer my question ;) – Timo Verbrugghe Jul 21 '14 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.