1

I've installed vundle on my ubuntu box but when I load vim none of the plugins load. My .vimrc from my home directory [some commented lines edited out]:

runtime! debian.vim
set nocompatible              " be iMproved, required
filetype off                  " required

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
"set rtp+=~/.vim/bundle
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')

" let Vundle manage Vundle, required
Plugin 'gmarik/Vundle.vim'
Plugin 'reedes/vim-thematic'
Plugin 'bling/vim-airline'

" All of your Plugins must be added before the following line
call vundle#end()            " required
filetype plugin indent on    " required
" To ignore plugin indent changes, instead use:
"filetype plugin on
"
" Put your non-Plugin stuff after this line

syntax on
set number
set ruler


" Source a global configuration file if available
if filereadable("/etc/vim/vimrc.local")
  source /etc/vim/vimrc.local
endif

:PluginList outputs...

" My Plugins                        
Plugin 'gmarik/Vundle.vim'                                           
Plugin 'reedes/vim-thematic'                                          
Plugin 'bling/vim-airline' 

I haven't changed any other settings, this is my first attempt at using Vim plugins. Vim loads looking like this... (default vim) pic

  • Cross-posting detected: superuser.com/questions/784915/…. – Dmitry Alexandrov Jul 19 '14 at 11:57
  • Take a look at the output of :scriptnames to see what was loaded. – Volker Siegel Jul 19 '14 at 13:03
  • @VolkerSiegel :scriptnames outputs the plugins I installed and more – CS Student Jul 19 '14 at 17:36
  • So, the plugins are loaded, right? What makes you think they are not loaded? – Volker Siegel Jul 19 '14 at 17:40
  • @VolkerSiegel They are loaded according to scriptnames but the appearance of Vim should be changed by the plugin vim-airline however all I get is the default Vim. Unless I've missed something really obvious. – CS Student Jul 19 '14 at 17:49
2

Your plugins may be loaded, but just not have a visible effect by default.

For example, the line

Plugin 'bling/vim-airline'

loads the vim-airline plugin, but you will not see the fancy status line until the status line is shown for some reason. (The bottom line in your screenshot is not the status line.)
The status line get's shown if there is a split window, or if the laststatus option is set to show it allways.

Try adding this line to your .vimrc to show the status line by default.

set laststatus=2

(According to the comments, this solved the OP's issue)


If you made sure you configured your plugins to actually have some visible effect, and still think it's not loaded, use the following command to list all script files that have been loaded in the current instance of vim:

:scriptnames

That shows a long list of files. If a plugin is loaded, you will see one or more files with names related to the plugin's name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.