2

I have reassigned my workspace switching keys to Super+h, Super+j, Super+k, and Super+l because the arrow keys are too cumbersome. They work perfectly except for Super+l which instead just locks my screen. This key combanation is very convenient for me as I don't need to move either hand from the homerow keys to switch between workspaces.

I'm using 14.04 (64bit). I reassigned my keys using 'All Settings -> Keyboard -> Shortcuts -> Navigation -> Switch to workspace X'.

1

You probably just need to unset the lock screen shortcut first:

Just click on the right side of the shortcut, and when it says 'New Accelerator', press Backspace to unset it

  • The lock screen shortcut (in All Settings -> Keyboard -> Shortcut -> System -> Lock Screen) has Ctrl + Alt + L as the key combo. Removing it does nothing for Super + L. I've looked through all the shortcut menus and can't find a different Lock Screen option or anything using Super + L. – Nicholas K. Jul 19 '14 at 13:06
  • Are you using Unity? - it has the (not so) nice feature of hard-coding things in for their 'design view' or something, which may be the issue... does setting 'Super'+'L' as the shortcut for anything else work? – Wilf Jul 19 '14 at 13:47
  • I am using Unity and nothing works with Super + L. It locks the screen no matter what I assign Super + L to. Is there a way to change the Unity hard codings? – Nicholas K. Jul 19 '14 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.